import .svg file

I can’t get Blender to import .svg files I created in Illustrator. My version of Blender does have the .svg import/export add-on, but I can’t get it to open my .svg files. I’ve saved several versions with slightly different settings in the Illustrator SaveAs window, and Blender sees the files on my HD, but when I click them, Blender just goes back to the 3D view, but there’s no imported mesh. I read that when you select the file there are supposed to be some properties that can be changed in the import window, but it simply says “no properties”.

This forum won’t let me upload the illustrator .svg file, but I feel like it’s a pretty straight forward design. I did note while trying to import the files in Blender that the file sizes are very small, as in just a few k, whereas the original illustrator file is about a meg.

Hello, I am using SVG files saved in Inkscape. Blender imports every path as separate curve. But the object is very, very small almost invisible on 3D view on grid - video at 1:35. Inkscape is free, try draw something and import to Blender. edit: For upload .svg to forum zip file first.

One thing to remember about SVG files is that they are terribly small in Blender. Are you sure the import really failed? You can confirm this by checking the object list in the Outliner window. After the import press the period key on the num pad to zoom into the selection.

I use the default settings out of Illustrator for exporting a valid SVG file that Blender can import. No change to the export dialog is needed.

Also to attach any file to the forum just put it in a ZIP file and attach the ZIP.

Filigree (209 KB)
I think I’ve tried everything suggested, but no .svg file will open in Blender. I made sure there wasn’t a tiny object anywhere. I downloaded some .svg files made by other people on here, but nothing will open in Blender. Could there be something wrong with my add-on?
Just in case, here’s the file I made in Illustrator, and am trying to open in Blender.

Thanks for the help, I cannot proceed with a big project until I figure this out!

When I resave your file in Inkscape it also want not be imported. I copy your curves and paste to new Inkscape file and save (clean SVG format) then Blender import it. In attachement .blender file


Filigree outline.blend (846 KB)

SVG made in illustrator contains huge amounts of cruft. In your file for example there’s some 420kb of meaningless illustrator only code. (try a plain svg option if you have one.) Inkscape is free and creates far more compliant svg.
Look at the size difference.


Filigree outline (6.07 KB)

Imported Inkscape .svg objects are in original sizes in Blender. Inkscape width and height 100mm are 10cm in Blender.

Thanks very much everyone!! I’m back on track, the Blender community is amazing.
Thanks again.

After import and convert Curve to Mesh there may be too much faces, you can dissolve some. About imported size - if you change Units to Metrics and add A4 plane, you will see that imported SVG is 1:1. Anyway SVG is scalable, so it is not a problem.