Importing models

Hello I am a total newby with Blender,just started working with this engine this week.
I have the following problem :

I have some models that can be opened with sketch up 8,and I exported them like a Collada type of file.So far so good.
When I imported them in BGE I faced some problems in moving the whole model to the area that I want,without dismantling it,I just could scale it but I can’t move it as whole.So I saved the model as a blender type of file now,and when I tried to import it after I reopened BGE,I pressed file / append / found it picked it with right click and pressed the button top right of the screen that says link/append from library and nothing happens,or they appeared somewhere where I can’t see them.I tried to mess around with the options a bit and all I managed is to get a “this is no library” error.

Any help? thanks in advance

Firstly, verify that the .blend file does indeed have information in it.

Navigate to wherever you saved the blend file, open it, make sure that the stuff is there.

Then, if possible, attach the .blend file to a post on this thread. That way people can look at it and get a better grasp of what might be going wrong.

Checked all that you said and it is ok.I upload it now.Btw it is not my model,I downloaded it from the google warehouse to use it.Also a question,do I need to press “go advanced” everytime to attach files?


Water_Trawler_28ft.blend (748 KB)

Hmm, I can link/append the boat fine.

File > Append > Selected the Water_Trawler_28ft.blend > Scene (folder) > Scene (thingy to append) > Link/Append from Library (the button in the upper right-hand corner)

Have you had trouble with different blend files? Try appending a different .blend file.

It may be possible that something is wrong with your blender installation. Maybe try downloading a previous version of blender, like 2.64, to see if that fixes the problem?

And yes, you do have to “Go Advanced” to post attachments.

I did not know I had to append the scene thing :stuck_out_tongue: .Should I always append whatever is in the scene folder?
I did that and now if I change the scenes in BGE I can see the 2/3 objects that I have appended.
I attached the only one that I can not see,it seems like it is placed somewhere far away,check it and tell me why please.
Also how can I take all 3 different scenes and make them into one? … so that all objects are on the same scene when importing them.And one last question do I need to delete the cube before appending them?

Thanks for the answer so far!


Orca.blend (1.57 MB)

Bump for anyone that can help me with the above.

In Outliner window select one of your objects, say KWHFL.003.
Hit . (that is dot) on numpad - this will bring viewport’s attention to your object.
Now, while mouse cursor is still in 3d view, hit N. This will bring up scale and position numbers panel where you’ll see that this “something” is HUGE and FAR away from blender’s default workspace centre. Also Camera is able to see just a part of it.
What you need to do is to bring selected object’s size and position in 3d space to more reasonable numbers - scale and translate.
That’s easy: just hit S .01 to get 100 smaller wale. It’s still far away, so now either write xyz values 0 for Location on N-panel or use some 3d Cursor magic - Shift-S Cursor to Center and immediately Shift-S Selection to Center.
Do not forget to apply scale and location - Ctrl-A.

Repeat for other things.
Now you can save file and use objects later without such problems.

Edit: if you intend to make something nice out of that cube, just leave it in. Otherwise delete it. :wink:
When all objects are scaled to some “common denominator size”, you could bring them into one new file, arrange Scene and save that.

Many thanks for the answer,took me sometime to put them in effect that is why I did not answer fast.
Got some questions in what you said.
Although I managed to scale everything and move it in the surface with the squares in the 3D view when I scaled I noticed the dimension on the “N” panel did not change accordingly to the scale I did.For example I scaled by pressing “.”(dot) + “S” + 0.1 and the first time the dimension x,y,z in the “N” panel became 0.0143 or something like that.I did the same thing once more in the already scaled object and it became another random number.So what am I doing wrong? …and also if I mess with the numbers in the dimensions immediately after I press “dot” will it scale it right?
Also I choosed Origin to Geometry before I scale,I read about that somewhere,but I do not know if it is wrong or right.
Leaving this aside the ship model kinda disfigured during the scale,no idea why.Happened when I tried to make it even smaller I think.

“Shift-S Cursor to Center and immediately Shift-S Selection to Center.”
Did you mean Cursor to Center and after that Selection to Cursor?..cause that worked for me and it moved the object to the center of the “level of squares” in the 3D view.

Then when I tried to append them,2 of the 3 items I had would only get appended if I left-clicked the scene file from the scene sub-folder in the .blend file.And 1 of them would get appended only when I right-clicked the .blend file itself.

When all of them would get appended I had,one scene and 3 other scenes with the names Scene.001 , Scene.002 , Scene.003.How do I arrange them into one Scene?

Edit:What does the “ctrl” + “A” options that you gave me do? Cause sometimes errors with mesh appear when I select the 2 options.

Bump again :slight_smile:

P.S. I don’t mean to bump often but I am stuck in this “importing and appending files” section and I can’t go on without fixing it.And I want to go on.

Sorry, did not notice your last posts.
“Selection to Center” was my error - should be “Selection to Cursor” of course :).
Ctrl-A brings up menu what to apply to object - on most occasions you want Scale and Location.
“dot” +S+ 0.1 sounds like a bit different from just S0.1 - not sure what happened there. However you can divide xyz values on N-panel by some number - say x is 2.34feet , so you add to that: 2.34feet/100 and get 100 times smaller x value. Just repeat for y and z.

What you want is Append objects, not scenes. So Object from another file will be appended in one you work and you wont get new scenes.
Whale model is a bit different from ship - it consists of 3 parts for some reason. Two fins do not share origin with whale; as a result they will appear inside whale when scaled and moved to cursor position. you need then manually attach them back. Select one fin and in edit mode with all selected keeping mouse cursor initially close to some border vertex grab G and move closer to whale. Vertex snapping should be on before.

To be honest, ship and whale mesh is not what you would like to see in blender. There are a lot of things wrong from it’s point of view ;).
There is a file with both objects in one scene (i did some ship cleaning too to some extent).
Hope helps, Happy blending!

Thanks for all the help and the file! :smiley:

Consider this solved,unless I should make it appeared solved somehow.Gonna check it now.