Incomplete strokes when painting pixel textures

Folks, I’m having a little trouble painting a pixel texture - I’m finding it difficult to draw a continuous line. This is something I’ve encountered before, but I usually just worked around it - now I’d like to find a solution!

My falloff is square, my brush is set to 1 with a hardness of 1 and the Stroke style is Line.

Any help would be appreciated - I’d love to finally master these tools…!

I think these settings need checking,


Space in stroke method set to 1% give me a continous line.

I think those settings are basically the same (unless I’m missing something obvious!). However, I’m still getting very broken lines (especially if I’m using Dots).

I should mention that I’m drawing on the mesh - does that affect anything?

Still getting breaks in the line, unfortunately…!

mouse or tablet?

I get a continous line with space set to 1% at 1px size brush.

Mouse. I think I have the same settings, but no dice. Are you painting exclusively in the Texture Paint panel, or are you painting on a mesh?

And thanks for your time on this, by the way! I’ll put an O between the Xs.

Texture paint panel, with a mouse and just tried tablet, tablet is slightly better in dot mode at making a consistant line, but space works for both.

This is driving me crazy. I just tested in the Texture Paint panel and I can’t seem to draw just a single pixel, it’s always 2+ pixels when I click, so that’s a new issue.

Space works for drawing a consistent line in the Texture Paint panel, but when drawing on the model I keep getting breaks in the line. =(

Im using blender 3.0 from a few days ago. Win 8.1 pro.

have you tried painting in a fresh file/ restart,

I can imagine you will find different results in the 3d window as its got to raytrace the position, so depending on size of model view etc this may not be too accurate, but its a guess.

Ok, just tried painting in 3d view, all good. 1px set to space, works on a sphere and a plane. all Blender standard object unscaled, with a texture map at 1024x1024, so as default as I can.

I can send you the file, to try your end if you are using Blender 3.0?

I’m using 2.93.5, the current Steam release, on Windows 10.

Just restarted Blender, loaded up the cube and Suzanne with the settings as above (1px set to space, etc):

You can see multiple line breaks, especially below the nose. It broke a few times when testing on cubes.

Additionally, you can see a few dots on the left where I tried to make a single-pixel dot, but instead ended up with 3-4 pixels.

I doubt I can use the 3.0 file, but thank you for offering!

Huh, seems like the single-pixel issue is related to falloff settings:

EDIT: Those falloff settings improve the pixel accuracy, but it’s exacerbating the painting-on-mesh issue…

1 Like