Initiative to build cycles cuda kernel for older GFX cards

Hi, as blender 2.61 not support older gfx card many people have problems to run cycles on the gpu in the future (rev. 42 573).
I would like to start upload kernel for linux 64 for “Cuda Compute Capability” 1.0, 1.1 and 1.2.
You find your card here:

As the kernel are small i put all in on 7z file at later.
For now i put it on my dropbox account:

You have to copy the kernels in to > /2.60/scripts/addons/cycles/lib
It would be nice if builder from other systems like osx and windows do the same.

Cheers, mib.

Good ol’ Blender community, thx mib

I added the lib 1.1 for my 8600 GT and when I turn on GPU it just says I must have 1,1 or later but detected 1.0 and will not run. It works fine with CPU though.

Hm, have you test with 1.0, i can´t test because i have a 1.3 card. We need more input witch card realy work and witch not.
If i build for myself the compiler put the kernel in /home/username/.blender/2.60/cache
Please try and report.

Cheers, mib.

@magic.crow: Your error sounds more like OpenCL :wink:
We are talking about CUDA in this thread.

Dingto you are correct. I made that mistake but how do you turn on the CUDA render? Do I need a different Blender compile? I don’t seem to have that setting now but I remember having it in the past.

Make sure you have an Nvidia card of course, then make sure experimental is turned on in the render settings, it will then give you an option of either CUDA or OpenCL when GPU is selected.


Make sure you have an Nvidia card of course.

Got that.

then make sure experimental is turned on in the render settings,

Did that too.

it will then give you an option of either CUDA or OpenCL when GPU is selected.

Sadly it does not. I get OpenCL and nothing else, thus my question. What version of Blender do I need? I have 64bit Ubuntu 2.60.7 r42503

hi magick.crow, may try the rc1 build:

There are the other kernels in /cycles/lib copy my kernels to this location, if this not work i can give up to build kernels for older cards :expressionless:

Cheers, mib.

Don’t give up!

So I tried everything I could think off but there is never an option for picking cuda. I know that there was in the past but they seem to have turned it off. Maybe graphical has some build that has cuda turned on? I have not had time to check.

I got new info from #blendercoders:

[12:00] <brecht> sergey-: it only works on < shader model 1.3 cards if you enable Experimental feature set

So you have to set to “Experimental” and then “Cuda”, hope it helps.

Cheers, mip.

That is the whole point/problem! There is no CUDA in the list only openCL.

Hi mib, downloaded your kernels and put them in the correct folder but when hit F12 or switch to rendered view i get:

CUDA error: Invalid kernel image
Failed loading CUDA kernel /home/alex/blender-2.61rc-linux-glibc27-x86_64/2.60/scripts/addons/cycles/lib/kernel_sm_12.cubin.

I’m on ubuntu 11.10 64, nvidia 290.10, cuda toolkit installed and a geforce gt 240, so it should go with kernel_sm_12… maybe it’s the card not compatible with the kernel compiled on your machine…?

Hi all, i think the kernel must match the exact blender revision and we should wait for 2.61 release.
I build kernels again with this revision and upload it.
If this not work my little plan is stranded. :slight_smile:
It is only one or two days, cheers, mib.

Edit: Ah , but you get cuda in the render settings and it should work with the correct kernel.

yes, and i’ve discovered that kernels can be compiled runtime on Linux, yuhuu! So I deleted yours and compiled mine runtime and it works :smiley:

I’m still not clear on why my card supports shader model 4.1, and I have the latest drivers which say as much, but I get that device error when I use the official RC1 build. Is there something with Quadro FX cards vs GTX?

MitchJ, on official builds only “Cuda Compute Capability” 1.3 and up is supported you can look here for your card:

If not you have to install cuda toolkit on linux and osx to compile the kernel at first render, set Render settings to “Experimental” and then “Cuda”.
We have to wait until 2.61 is out, it includes also linux kernels 1.3 2.0 and 2.1.


Ah, great! Thanks for the quick response, mib2berlin :smiley:

Tested with 9600 GT, works beautifully fast! Again, “Experimental”, “GPU” and “Cuda”, for those of you curious.

Just wish the support for this card was available by default though.

EDIT: Okay, so crashes are frequent. XD The application keeps shutting down.

I am curious how is the performance of the GPU renderer on an older card like the 9600GT compare to that of a modest dual-core cpu?