Intel gfx fix: please test!

After a long session in IRC with Sergey Sharybin we found a way how to make Blender open User Preferences (and other windows) safely on Windows Intel gfx systems.

A new Win32 binary can be found at:

There’s no official Win64 build, you could try to find one on graphical. retquires minimal svn revision 36070.


With my G31/G33 on XP SP3, in all the various builds i tried, i had never noticed a crash when using File -> User Preference or just creating a split window.

Anyways, i tried the from the 1st link and observed no crash either.

But there’s a difference in regard to when i press M (to have the floating layers panel) after loading a new model each time .
In previous builds, in Window Draw Method set to :

-Overlap : the M floating panel was flashing and went invisible, i had to move the cursor and re-press M to have it appear correctly, lot of flicker in the various panels when having a floating panel around.
-Same for Overlap Flip , invisible and lot of flicker when having a floating panel.
-Triple Buffer was working correcltly

With this new build :
-Overlap : the floating panel do not flash and disappear anymore, but on the panel to the right , some part of that floating panel seem to appear over it :
-Overlap Flip, no problem out of a very slight very brief flicker on the panel to the left once i click on one of the button of the floating panel. The floating panel does not flash and does not disappear when pressing M for the 1st time, nothing appear over the right panel, it seems correctly functionning
-Triple Buffer, always no problem, rock solid and no slight or brief flicker anywhere when having floating panels around.

Do Intel Processors count?
Cause i still have this problem:

This thread was open by Ton as well.

The fix actually made it worse… I had no problems before with opening a second window but now blender crashes…

My specification

OS: Windows 7 64-bit
Intel GMA 4500MHD
renderer:   Mobile Intel(R) 4 Series Express Chipset Family
vendor:     Intel
version:    2.1.0 - Build

Please, retry to reproduce crash with our official builds (2.56a, RC1, RC2), builds from buildbot. If they’ll crash, please show me output of command “blender.exe -d” with binaries 32bit or 64bit.

Hi I tested with a couple of build (note that there is some problem switching between modes in 64-bit builds):

2.56a 32-bit: OK
2.56a 64-bit: OK (however crashes when switching form tripple buffer to any other mode)
2.57 RC2 32-bit: OK
2.57 RC2 64-bit: OK (however crashes when switching form tripple buffer to any other mode)
Blender 32-bit r36097 from buildbot: Crash
Debug 32-bit: Crash
Debug 64-bit: Crash

Is the debug log stored anywhere, cause I didn’t manage to find any? However here’s some print screens of the frozen console windows:

64-bit info

The crash may be cause by a bug in Intels graphic drivers. For me it worked when I updated the newest drivers.

I’ve commited one fix to this stuff this night. It prevented crash for Dalai’s NVidia configuration and it could also prevent crash for other configurations bue to it happend NULL-pointer dereference for special cases (when current contest was set to NULL by redraw stuff).

  I heard there was crash when calling userprefs from neu but no       crash whel calling by hotkey. This case could be fixed now.
  Anyway, we need power of our community to test builds. Win32 could       be found [here]( and win64 is       still at []( (you need revision >= 36104)

Does this effect Intel chips which have Linux running, or just Windows?

Gustav, try my fix builds from as well. (36104)

Your build worked fine. Is the fix suppose to work with older drivers as well? Then maybe somebody else who have old drivers should test. Cause currently I’m running the latest Intel drivers which fixed the problems I had previously…

yeah, worked for me and at least the x3100 gpu. btw: fix was committed to the trunk (36115), so i removed my builds.