Intelligent baking that includes bumps and valleys of meshes that were not there before

My source mesh Original is not watertight and has some minor other mesh errors.

I duplicated Original to Kopie and made Kopie watertight, while removing minor mesh errors, smoothing with Dyntopo, subsampling. Now some areas are thicker than in Original, others thinner.

I baked the texture onto Kopie by using Ctrl and first selecting Original, then Kopie then bake.


The problem is that baking is not 3 dimensional.

Therefore, wherever I modified Kopie, no texture is being transferred and Kopie's texture shines through, which makes the final Kopie texture patchy.

How do I get an “intelligent bake”?

PS: Original has multiple materials, if that matters for a reply.

Hey Orin_Weng,

It is quit difficult to understand what the problem is. A viewport screenshot would be a good reference, or maybe copy of the .blend file.

When baking “Selected to Active” there is an option “Ray Distance”.
You could try to make your source object little bit bigger then the “Kopie” object, so that it covers active object’s surface like an extra layer. Now you could play with the “Ray Distance” value, as it determines baking distance from selected mesh (“Original”) to the active (“Kopie”) one.

1 Like

Any new faces you created are not unwrapped and don’t match UV coordinates in the original mesh.
No texture transfers because nothing is mapped to them.

Ray distance was exactly what I was missing. Thank you so much!

1 Like