Interface Problem on a HP 6710b notebook

I have been using Blender for a while now, and have tried to start using it on the Work Notebook (HP6710b).
The application starts and runs fine, untill I need to use something that uses the cross hairs or selection tools. For example when I use the box select methods the guid lines do not appear, the functions work, but the guides just do not show up.
I thought this could be a problem with the drivers for the Graphics card, but updated them to the latest problem and it still happens. Any thoughts on where to look.

This laptop runs on the Intel GMA X3100 graphics card, right? There is not much you can do once you got the latest graphics driver. Maybe try an earlier version? :smiley:

You can try turning down graphics hardware acceleration, but this is probably not a good idea if you play other 3D games, or running Vista.

Edit: Actually, if you are running Vista, did you try turning off Aero interface?

That was exactly it. I was looking at the other Modeling package I use and thought that with this one I have to turn it off, maybe it will work with Blender… and it did the trick.


I am reviving this old topic, becouse i am experiencing problems with Blender + X3100. The problem is, that disabling Aero and destop composition does not solve anything. I only see a black screen when I run blender. I’ve tried this on Windows Vista and Windows 7 - the same results (both 32bit and 64bit builds). I have tried to use different video drivers, but with no luck.
Maybe you have any thoughts about what could be wrong? I’ve seen people using blender with X3100, so even if this is not a good video card, it should still let me use Blender.

Any help is very appreciated.

blender 2.5 is suppose to be a lot nicer on non-nvidia video card due to the way it handles the buffer swap.

van, i am assuming you are not running dualscreen? or using anti-aliasing or something? the only other option i can think of is try running Linux. sorry mate.

You are correct - no dualscreen, no anti-aliasing or other fancy stuff :smiley: Well, Linux might be the answer until 2.5 is released and then we’ll see. Anyway, thank you for the answer. If anybody else has any suggestions, please post them here, because I do not understand why my machine is differenct from others, running X3100 + Blender.

there was one instance where disabling Aero actually makes blender not work for me. So i would also suggest you try enable aero and see if that works. Also try running at 32bit color? 16bit/24bit might be problematic.

I have already tried everything you mentioned here. Actually, I have tried ten times more things than you mentioned :smiley: Logical, illogical - anything that could have any influence on Blender.

Today, I’ve downloaded a few linux distros, to see if that makes a difference. Well, it did. The results so far:

PCLinuxOS - Blender works like a charm
Linux Mint - Blender works well, but has some viewport rendering problems
Linux Ubuntu - Same as Linux Mint. Probably because Mint is based on Ubuntu.
And I’m downloading Linux Mandriva, just for further testing :slight_smile:

Hope that information helps somebody else having similar problems.