Inverted render order bug

Okay so im trying to make a game… i admit im a bit of a noob when it comes to blender.

in the 3d view, the mesh looks completely normal, but when i switch to the game engine, the model looks like this:

Some help would be greatly appreciated.

Edit: Heres the file, this way someone more experienced than me can look at it

Go into edit mode and press ctrl+n to make the normals consistent.


The faces are pointing inside the mesh. The result is that you see the faces from the inside (not from the outside). Solution flip the face normals (see post #2).

May also be an alpha issue. Seeing as all of these objects are not transparent, set the materials to “Opaque”

I have already tried fixing the normals several times, and have played with the alpha blend mode. still no results.

also make sure the visibility mode is not set to x-ray…it does not seem to be the case here, but just another FYI that x-ray objects draw after all other objects.

Added link to the file. still looking for a solution

Why have you enabled transparency for all your materials, it does not look as though you need it. Turn it off for all the materials

to be honest i didnt do that… i imported the model so everything you see was done by blender. Either way, turning off transparency fixed the problem :3