is 2.42a that different?

after installing 2.42a, when clicking on the shortcut, blender would take over 5 min. to open, I’ve had several other versions & never had a problem…I was chased from the general discussion to I guess here? I have to download driver updates [I think I have a “geforce” FX5200 graphics card?]. 47+ megs, just to run 2.42a??? [I’m dial-up]…to be honest, I was not that interested in 2.42a & was happy w/2.41. I was asked to teach blender & felt they should start w/ the latest version. sorry if my questions seem dumb.I guess I’m more art than tech…thanx for any help…johnd

It definitely should not take that long, maybe five seconds at worst. Why do you think you have to download driver updates? Your drivers should have nothing to do with launch time; it either opens, it doesn’t open or it opens but garbles the GUI/has trouble drawing buttons or menus on mouseover.

Knowing your OS, Video Card and Virtual Mem allocation would help.

The big updates to 2.42a were Nodes and the render engine, neither one of which will have any affect on launch time as they’re only invoked once the exe is running.


I have an AMD64-3200 processor & 2gig of ram,I had this machine built just for my blender animations,& from info gathered at this site…where ever I find someone asking about blender being slow, someone always seems to recommend driver updates, here & at blender support…thanx, if drivers
have nothing to do w/ launch time,then my problem must be elsewhere.
OS=“windows XP professional”…which I got ripped off on & just had to pay microsoft $150 to make genuine,[ is it possible that could cause a hang-up?]

I don’t think that’s it… I use XP Professional here at the office and at home and I’ve never had Blender take more than a few seconds to start up. It seems to take longer the right after re-booting (makes sense, no libraries are in memory yet) and after I use a really memory intensive program.

You have ample RAM but do you have enough Virtual Mem? Do you hear your box complaining while Blender launches?


2.41 launches in under 5 seconds… how do I check “virtual memory”…I’ve had 2.41 since it came out. when I seen I was having trouble, I saved 2.41 & an optimized version of 2.37 to disc then removed all blender from my machine. when I reloaded 2.41 it was different then what I thought I saved…the zoom is reversed for one, the 3 color xyz arrow appeared,it had not been there before & that left click thing it didn’t do that either before…yep I’m a little confused right now…but, I think I’m gonna go try n’ download a fresh version of 2.42…thanx again, wish me luck…as usual…johnd

There “shouldn’t” be any difference in loading time for 2.41 or 2.42a. I have about 10 different versions of Blender on my p.c. (Win XP) they all load basically in the same amount of time.

There are some very handy utilities here

“FileMon” and “Regmon” are two very useful ones. They monitor all reads/ writes to the file system / registry so that you can see what a program is trying to read/write … any errors that are encountered. (Neither of those programs “install” anything to your system directories)

Do you have Python installed? I’m running Python ver 2.4.2 without any problems.


OK, I just tried again, if this tells you anything, on the install the green bar zipped across til the last 3 bars, that took at least a minute, it replaced the icon on my desk top that was 2.41, took its 5 min. to open, it worked but was clunky, & would not run an animation, the uninstall took about 3 min…I hope this info is useful if someone else has a similar problem…I’ve defraged n’ cleaned everything up, my 2.41 installed in seconds n’ I hope I have better luck w/ 2.43…thanx again all…I’m gonna go enjoy my blender…johnd

Where is the blender.exe from? There is a firewall that had issues with blender, apparently one method of building results in the inclusion of a standard windows printer dll that trys to connect to a network and that causes huge load times. That should have been eliminated though.

Ah I recall the name now - zone alarm.


hey thanx, but I really don’t have a clue as to what your saying, sorry…I downloaded from the first row on the blender site download page. [w/ installer?]…I’m not connected to any network, I tried 3 seperate fresh downloads…does that mean if I have “zone alarm” that’s my problem?..I have a lexmark z-42 printer but I don’t think that’s where your going w/ this?..thanx again …johnd