Is Blender secretly French ?

Anyone know if these 2 really frustrating bugs will be fixed in the new upcoming 2.43 release ?

Bug 1
Ever since I have been using Blender, quite often the keyboard mapping occasionally screws up and the keys change letters. I know this sounds stupid, but I have just realised my UK keyboard when it screws up, actually switches to the French “AZERTY” keyboard mapping. Kind of hard to use when “Select All” switches to “Quit” :mad:

Bug 2
The other annoying bug is every now and again the mouse wheel zoom suddenly stops working for no reason
Both Bugs are the same in that they can only be fixed by quitting Blender and restarting, unfortunately I have still not been able to spot precisely what I did that triggered either bug

For Info, I am using Windows XP and Blender 2.42

Regards Geoff

lol i have never heard or experianced any key being switched…are u sure that you arent hitting v"cntrl = alt" at the same time and switching beetween maps urself??? lol

Bug 2 - I have no idea how to help. Try installing drivers for your mouse shrugs

Bug 1 - I had same problem. Compination of alt+shift (very often used thing) changed my keyboard from qwerty to qwertz.
Disable the keyboard shourtcut in your language settings. This combination changes the keyb setting in windows by default.

They won’t be fixed in the upcoming release because they’re not blender bugs, at least, the first one isn’t. I had the same problem, and fixed it by upgrading my video driver. There’s a fairly comprehensive discussion in the “Commonly Asked Questions” sticky in the Basics and Interface support subforum.

Come to think of it, my mouse wheel hasn’t misbehaved in a long while, either, so maybe its a fix for both problems.

[I thought Blender was secretly Dutch…maybe the Dutch use French keyboards? :smiley: ]

Thanks for the help guys

You might be right about them not being Blender bugs, but I am not convinced.
I have been doing some further experimenting

Bug 1
I can now reproduce the problem almost on demand,occurs about 1 in 3 times if Ihold down left Shift & left Alt and right click mouse. Also when Blender switches keyboard, all other Apps do not switch.
I have now fixed the problem by switching off the Windows Keyboard switching via control panel. Blender was switching on left Shift & left Alt and right mouse this didnt really make sense, I still think it is a bit of a Blender bug. But anyways I have got a workaround fix now

Bug 2
I am using NVidia 92.91 which is pretty much up to date, also I have read reports of other people suffering from this problem

Regards Geoff

Bug 1 is not a Blender bug. Not “sort of” a bug or anything. It’s a WINDOWS/keyboard thing/feature. It’s just a shortcut defined outside Blender – Blender has no control over it and shouldn’t (can’t?) be coded to “fix” it.

As for #2, never heard of it myself.

Systemsteuerung > Regions und Sprachoptionen > register card: Sprachen > Details > Box: Einstellungen > Button: Eingabegebietsschema-Leiste > check off all boxes

System Control Center > Region and Languageoptions > register card: Languages > details > Box: Settings > Button: ^^ no plan how i should translate this > check off all boxes

This works, but I have a German PC and I don’t know how it’s called in your localized version of windows ;).

Bug 1 is not a Blender bug. Not “sort of” a bug or anything. It’s a WINDOWS/keyboard thing/feature. It’s just a shortcut defined outside Blender – Blender has no control over it and shouldn’t (can’t?) be coded to “fix” it.

The reasons I said that were

  1. The key/mouse sequence in Blender that triggers the switch for me, was not the exact combination defined in Windows control Panel to switch keyboards

  2. After Blender had switched I tried 2 MS Apps, neither had switched keyboards
    The problem is clearly related to that Windows keyboard setting, but I still maintain Blender is not behaving quite correctly

Regards Geoff

Windows remembers the application where you switched keymap settings.

I know what you mean. I use 2 computers which one is a laptop. My Desktop pc runs Windows XP without service pack 1 and 2 (I know old, but still never had problems with it) and I run a Laptop with Windows xp using sp 1 and 2. Now on my Desktop pc I never have the problem that the function of the Shift and drag, or mouse input disappears. But on my latop I have it very ofthen, and it can be fixed by minimize Blender or save the file and reopen it to get the zoom, drag an another mouse functions back. It’s really weird, I thought it was my laptop, but now more people complain about it. :S

I too have been having the same problem with my mouse wheel, it just stops responding and only in Blender.

Yup. That’s exactly the problem I had. I even went to the developer wiki to report it. Once there, they recommended that I 1) find the exact keystrokes to replicate the problem (found the same sequence of keystrokes you did, GeoffW) and 2) see if the keystrokes cause the same problem on a different machine. So I took the problem over to my laptop and… the problem wasn’t there. So I upgraded the video driver on my desktop, and the problems stopped. Completely. No workarounds required. I’m telling you guys, upgrade your video drivers. They’re buggy.

I have encountered the second bug on more than one occasion. Only very rarely though.

i have a solution, install linux.