Is there a way to disable mipmapping for video textures in the game engine?

from bge import logic, render, types
from bgl import *


This works for all textures in my scene except the video texture for some reason. I’m using another camera as the source (renderToTexture) but for some reason there doesn’t seem to be a way to turn off mipmapping for only the video texture. Is there an alternate way to circumvent this??
Texture on monkey is correctly “pixellated”, while the video RenderToTexture behind it is still blurry
(edit - goal is to have a retro pixel 3d result without it being blurry)

There’s an option as far I remember to disable mipmaps when you set your render to texture…
for example:

#incomplete script
import bge
from bge import texture

bge.logic.tex = texture.Texture(obj, 0, 0)
bge.logic.tex.source = texture.ImageRender(scene, rendercam)
bge.logic.tex.mipmap = False
1 Like

Thank you! I tried implementing this in the script I am using but it doesn’t seem to be working.
Here’s the “setup” (without successfully disabling mipmaps)

import bge

from bge import render

controller = bge.logic.getCurrentController()
owner = controller.owner

cameraName = owner['cam']
materialName = owner['material']

scene = bge.logic.getCurrentScene()
camera = scene.cameras[cameraName]

materialId = bge.texture.materialID(owner, "MA" + materialName)

renderToTexture = bge.texture.Texture(owner, materialId)
owner["RenderToTexture"] = renderToTexture

source = bge.texture.ImageRender(scene, camera)
source.capsize = [320, 240]
renderToTexture.source = source

I should probably have included it in the OP. Anyway, then I refresh it using the following every frame:

import bge

controller = bge.logic.getCurrentController()

So far no luck, even by adding “from bge import texture” and then those lines of code below it to the “setup” script it doesn’t seem to be working for me…

I tested and it seems the option to disable render to texture mipmap doesn’t work neither in bge neither in upbge.
I share my test file anyway:

EDIT: this file is saved with blender 2.79