Is there a way to keep my interface from being sluggish during a GPU render?

Whenever I do a GPU render with Cycles, my UI (both blender and Windows) slows to a crawl, making my computer practically unusable. Is this a problem the devs intend to fix? Are there any tips out there that may help reduce or eliminate the problem?

Thanks guys!

That’s what the GPU is used for; when you put it to work, the normal operations it does don’t work as well. You’ll find the same will happen with most other GPU renderers.

Only three real options: either use the CPU, buy a cheap second GPU for general computer graphics while your other is used for rendering or render when you aren’t using the computer.

There might be a efficiency increase in the future, I don’t know.
Possibly there might be another solution, I don’t know about that either.

Hope that helps in one way or another,

Well, I don’t know if its an efficiency thing as much as allowing the UI to take priority over the render. Perhaps there is some kind of priority setting that the GPU would respect. Or maybe that’s just how nvidia’s drivers work and there is no way to change them, I don’t know.

I’m on a laptop and use the Intel HD 3000 video controller onboard my i7 CPU as primary video while I command line GPU render using my discreet Nvida NVS 4200. It’s the two card scenario Sam M points out and my system is responsive using CPU render Blender.

I mention this as I wanted to point out that some modern processors already supply that second card. Now if Intel would release a driver with OpenCL support for their on-chip GPU, I could use it for Cycles and be fully functional.

I too have this problem and am new to understanding how hardware works with renders… so if my GPU is sluggish (ati radeon hd 57xx) then it’ll use my CPU ‘as well’ or ‘instead’? Also if i were to run dual SLI, it doesn’t help render speeds, right?’s what the GPU is used for; when you put it to work, the normal operations it does don’t work as well.