Is there anyone using Blender on AMD Radeon + Linux (Wayland Gnome)?

I had posted about a similar problem, but back then, I thought it was a problem of a specific file. But it seems that Blender randomly makes Gnome shell stuck at a black screen, if I move drag the scene with the middle mouse click on the render view mode. When this happens, I have to basically log out and re-log in to use the desktop again.

It was not a complicated scene, just an icosphere with 4 subdivisions + auto smoothing and alt+D’ed it 5 or 6 times and enabled field of depth. HIP was enabled only for the AMD GPU and CPU was not checked. Render = Cycles + Supported + GPU Compute.

I did not have this problem on Nvidia + Windows, and not during the short period time when I was trying to use Nvidia + Linux. Due to Nvidia’s Wayland problems, I switched from Nvidia to AMD Radeon, and freshly installed Linux (Manjaro → Endeavour OS, both of which are based on Arch and are similar). I am using Wayland Gnome, fractional scaling, and dual monitors.

I would like to know whether this is a normal experience for Blender + AMD Radeon + Wayland Linux, or if there are people who are using Blender just fine under Blender + AMD Radeon + Wayland Linux. If it is the latter, maybe I need to buy an AMD Radeon card from a different manufacturer.

Manjaro Gnome, RX580, Open Source drivers (not hip). No problems like this, never ever.

Well, I have done some more research, and it seems that this problem exists only for RDNA2 cards. I think I can wait about year and even after that this problem still exists for RDNA2/3, I think I would move to Intel Arc.

Looks like they sell these cards with buggy BIOS. I tried two different RX-5700XT in a Non-UEFI board and got only a black screen. It didn’t even boot. Had to insert a second older card just to make it boot. But this results in all kind of driver hassle and runs hot because of limited space. I ended up returning the cards.
End of RDNA story for me. Never again. Might also try Intel, when i hear more positive resonances about it. No Bananaware anymore.

I use a Radeon Pro W6800 and Arch Linux. I’m using X, rather than Wayland. I’ve had zero problems.

In my experience, Wayland is buggy as hell, and I recommend staying away from it.

Please elaborate “Buggy as hell”. Without examples to reproduce it is quite useless as bug description. Or did you just wanted to promote your “error-free” 2500 Dollar graphics card?

Do you always act like this, or is today a special occasion? I’m not bragging about anything.

Weyland is well-known in the Linux community for being buggy as fuck comared to X.

Weyland is buggy enough that I had problems with it the one time I tried it, went back to X, and have had a relatively stable experience following.

Yes, always like that ;-( Never heard about these problems and you still did not even drop a single example. I think it is plain bashing. And i said please. My guess is that the RDNA drivers are badly written and incompatible with Wayland. I had to return two RX5700XT due to incompatibilities with Non-UEFI Bios. Now i suspect they had the problems with Wayland and not the Bios alone. That would also explain, why i could not find the exact reason. Several bugs on top of each other. I stay clear of new graphics cards for a while, as i am quite content with my old Polaris card. No probs so far.