Is this a particle system bug

I was playing around with the particle system, and tried to use the “VGroup” box on the Particles panel to limit my emitters to just a few vertices. I set up the vertex group of my emitter to have 4 vertices, went back, added the name, and to my surprise only one vertiex actually emitted particles.

When I went into weight paint however and subtracted some weight off of at least one vertex then I got emission from all 4 vertices.

Very strange. Seemed like a bug to me, but there could be some subtle reasoning for that behavior that is just escaping me.

I’m using the latest 2.45 build on Windows XP Professional (it also happened on 2.44, I upgraded to 2.45 to see if it was one of the misc. bug fixes).

I have a workaround, but it just seems kinda wrong.

This seems to be a little bit of a bug. But it’s trivial to work around by setting the vgroup weights at non-1 values, and most particle focus lately has been on Jahka’s new particle system, which will blow the old particles away. If you are doing serous particle work, you might want to check out the builds of that system at It will be available in the next blender release.

Thanks for the insight. I was more experimenting to see what I could do. Looks like I’ll get to experiment more with the next release! :slight_smile: