Issue: "Twitching" textures in Textured View. (Included .blend)

Hello everyone,

I’ve been trying to develop a game (obviously), and when I switch into textured view to do texture painting, the textures I have UV mapped and applied to the object “twitch” and get all messed up, especially when I start the game (Press P). Is this something I’m doing wrong, or is this a bug?

The object in question has ranged from 4,000 to 16,000 polys. I’ve tried lowering the poly count to see if that was the issue with no luck. Re-enabled mipmaps, nada. Different Mesh, nothing.

Is there anything I can do to fix this?

Hardware/Software Details:

Blender 2.68a Game Engine
Windows 8 OS
Intel HD Graphics (Factory HP Graphics Card)GameDev2.blend (1.13 MB)

You forgot to “pack” the file/textures!
Anyway, I’ve changed your missing texture/images by one of mine and it works well!
Your graphics card its a little “special” I guess, so go with the “basics”:
power of two ( 512x512 or 1024 x1024 max) image size, JPG or PNG format and in the worst case, no GLSL!

Sorry, I was in a hurry to get it solved I forgot to pack them. I only use textures in a power of two, so It’s just my computer I guess. Thank you for the reply!

Well, I still think it might be the poly/vertex count as well, actually. Because, I just tried on a more simple model (around 300 verts) and I got the same problem on one triangle, but once I removed the doubles it displayed correctly. I’ll find a way to work around it eventually. I appreciate the help, in any case!

My first thought was you forgot to set Texture Mapping from Generated to UV. But you already did that.

It is suspicious when the render preview (material panel) shows the small tiles too. In such a case it is a problem of the Material as the preview has it’s own mesh.

I think when I tell you what the problem is you will slap your head :wink:

look at the Texture tab/Mapping setting (and there the last couple of controls) In doubt play with the values :spin: or compare with a newly added texture.

Thank you for the reply, Monster.

You may think of me as an idiot, and I’m not offended if you do, but I don’t still don’t understand the problem. I looked under the mapping and saw nothing wrong, my usual settings for texturing. Unless I completely misread what you wrote, which is entirely possible seeing as I’ve been getting little sleep lately and my brain is a bit slow at the moment.

If you’d like to take another look, I’ve packed the files this time.


Rock Texture by *Nobiax (deviantART)
Sky Texture by Frecle SkyPanorama

:GameDev2.blend (5.62 MB)

Hello again,
your objects have “normals” pointing the wrong way!
Once corrected, the file works well…don’t use TGA format for “basic” textures, keep it where transparency is needed!
Use mainly JPG with 85/90% compression, its a good compromise quality/file size!
ps. Try with a simple cube, if it works, make simple games, maybe?

Well, I use the .tga textures because that’s what they are stock where I get them from, I then bake the textures to the UV map and save the image to .png or .jpg.

The game I am making now might require a more powerful engine, but as of now, I can’t find any good game engines the have a very friendly UI. I’ve tried Unity, but I’d need the Pro version features and I don’t have $1500 to shell out for it. CryENGINE 3 was good until I saved a file, closed, and reopened later to find the textures messed up.

Thank you for the tips, I’ll keep them in mind!

And if you wouldn’t mind suggesting a good, preferably free, game engine that runs on python scripting, I would very much appreciate it. I love Blender to death, but I also need to have certain features available, such as particle instances, video textures, stuff like that. I’m sure I could do it with a script, but I’m still learning python scripting.

Thank you all for your help!

You can see it in the preview view … the sphere has a lot of small tiles too.

(using the color grid)
Your texture has a size of 25 … which in difference to mesh scale makes the texture appear smaller (not larger). Because of the repeat your get your texture 25 times repeated rather that just once.

Simply set both sizes to 1 and you can admire the beauty of your texture in full size.

(the same color grid with a size of 1)

I guessed you had problems because of the tiled texture because I do not see any further problems (except the missing texture).What I can see the normals are pointing up as it should be.

Maybe you mean something else. In that case I’m sorry. I do not see it.

This is what I get after correcting the size:

Well, I had it tiled to be 25 x and 25 y, so I could get the texture tiled to the proper size. Afterward, I would bake the texture and re-enter it to the mesh at 1 to 1 scale. Maybe I could edit it from the beginning in GIMP. My main thoughts are: I usually set the tiling to be more than 1 to 1, and it would display fine. Ever since the latest release I have had this happen. I’ll just set the texture in GIMP before I place it onto the mesh from now on. Thank you for your help.

I have discovered that the problem really lies in my PC. I tried the same island scene with the same settings on my laptop, and it works fine. I thank all of you for your kind help in my dilemma! I think I can say it’s solved. I do have one question though, is there a good workflow for recalculating the normals besides the “Recalculate Normals” button? I have found the the button sometimes doesn’t get it quite right and flips normals that were face the proper direction to begin with. I could do it by hand, but that could take a while.

Well, “Recalculate normals” is the “good” tool…but sometimes you object have faces not “connected”, so when you recalculate/switch normals, the “good” ones became “wrong” and vice-versa!
Select the “good”, hide them, then select the “bad”, press W key and choose “Flip Normals” in the pop-up menu.