Issues with TAB-key for Mode-Switching in 3D Viewport

Blender’s TAB key operation for mode-switching is currently super unreliable, in my opinion:

  1. You have to RELEASE the key before anything happens. Just pressing TAB won’t switch modes.
  2. You CAN’T MOVE THE MOUSE, at all, when you press TAB – the mouse cursor has to be absolutely dead still, otherwise no go.

Am I the only one on Earth struck by this? As a Blender starter, this is the only thing that ever reached my nerves; 4 out of 10 times, pressing TAB does nothing … Prior to investigating the matter, I couldn’t quite put my finger on why mode-switching felt so unpredictable. Because it wasn’t related to project complexity and TAB always worked flawlessly in other programs. So. Here’s my specific question :

How can I TAB-switch between Edit/Object Modes in the 3D Viewport, without being required to first release the key, and then also minding that the mouse cursor is absolutely dead-on still?

Using shortcuts based on 2.7x I can’t repoduce ur problems. When pressing tab it is immediately switching to edit mode. When holding it down it steady switches back and forth between object and editmode. No need to release the button for switch.

Your problem might be dependent on high polycount of your object which slows it down to switch modes. But also with high poly switching between modes works solid when pressing down tab one time and release, just a lil delayed…

Edit: Needful to know for b3d beginner: b3d viewport performance especially in edit mode is still very poor…

I’m using latest 2.90.1 on Win 10 v2004 and this is the same with a completely empty project except for a default cube.

Ok, Idk but something else must be wrong. Maybe Gfx driver problems. I use b3d for a very long time and never encountered such behavior

Maybe delete your user settings under user/appdata/roaming and reinstall b3d

I sure hope not. Maybe someone else could chime in and confirm I’m not alone in this? Thanks for replying, dave.

If using Nvidia gfx. i could recommend 456.xx driver which work great for me using actual builds.

Good luck

I’ve solved my entire problem. Points 1 and 2 are now complete and utter history. :smiley:

Here’s how to solve it, for anyone having the same TAB-key situation:

  1. Go to Preferences > Keymap
  2. Type mode in the search field
  3. Scroll down to Object Non-modal: Set Object Mode
  4. Set Tab key to Press (mine was set to Click)

Heaven!! Proper, fast, efficient TAB-switching … my lord.

That’s strange, as Press is what it is by default.

Yeah, sometimes life works in mysterious ways :slight_smile:

For a key, what does ‘click’ even mean?? :face_with_raised_eyebrow:

If ‘click’ isn’t a valid action for keys, that should be checked for automatically and ghosted out.

Press followed by release.