Issues with Textures - Need help!

Hi guys,

Been a while since Ive been here :3

Just got a bit of an issue. I have a Texture with transparent “spots” thatd id like to keep transparent.

The supposedly transparent parts show up black. Ive tried setting the Alpha too.

What am i doing wrong? :spin:

I assume you are using the blender internal renderer since you don’t state otherwise.
For transparent textures
In the material settings turn on transparency and set alpha to zero
In Texture panel:
Image Sampling enable ‘Use’ Alpha (assume your texture has an alpha channel)
Influence enable Color and Alpha

If you still can’t get it working attach your blend file with all textures packed.

Already done all of that. And the texture appears transparent in the UV editor when i check the “channels button” to show alpha.

Still does not work (its a png btw) and yes. using internal renderer

Here is what i see.

Left is a rendered version. Right is in the UV editor.

Not enough info

what other info would you like? (before i upload)

An example blend file and all textures that clearly demonstrates your problem. Only the relevant model and texture is required, remove any other irrelevant bits

ive no where to upload it to.

Also It seems that when i change the image sampling from the EWA filter to the Box filter and uncheck interpolation (i need to do this to keep the pixelated look) is when it looses the transparency :frowning: