I've enabled some viewport xray mode, 2.8

Faces facing the camera are not being displayed, sort of tranparent/xray in viewport object mode, solid, and even with matcaps. What have I enabled here?

Try shift+N in edit mode

1 Like

Sweet! That fixes it, any clue why you would want that crazy mode?

You have backface culling option turn on in the viewport shading panel and you had some face normals inverted. So they will be hidden if you look at their back side.

1 Like