Jagged subsurf : newbie needs assistance please.

I’m new to blender and so far I love it.
I’m learning the interface and have not yet learned much about rendering.
I have rendered an object and it seems not to be rendered as it should: it’s a bit jagged and I can not figure out what is going wrong. (I’ve searched the manual and the forums.)
It is not a Blender resize problem I guess because the render is only 800x600.
OSA is enabled (8).
Only when I freeze the object with subsurf one, and add a new subsurf with Render Level 5 it renders smoothly. (Render Level 6 makes Blender crash!)
Thank you for helping me out.
render: http://users.skynet.be/dominus/blenderpics/tire6.jpg

I solved it I guess, although I do not know exactly how.
I deleted the subsurf modifier, did CTRL n-key (Recalculate Normals Outside), added a new subsurf and with only Render Level 2 the object rendered fine.

Could anyone explain me when you have to Recalculate Normals Outside ?

Thanks, Dominiek.

Succeeded render: http://users.skynet.be/dominus/blenderpics/tire6Succes.jpg

Did not have time to comb through all of these.

You have to recalculate the normals from the outside when they’re not all pointing to the outside but you need them to.
Edit mode > Editing (F9) > Mesh tools one > Draw normals :wink:

What you do if you want a smoothed looking mesh in Blender when you render is:

  1. Select your mesh you want smoothed.

  2. In the F9 menu, under “Links and Materials” panel (on the left), there’s a “set smooth” button at the bottom of that panel.

Alternatively, you could use hotkeys to quickly set smooth. To use the short cut hot keys, press:

W - > Alt + 3

. . .when you’re in edit mode and make sure all your vertices are selected if you want the entire mesh to be smoothed and not just part of the mesh.

  1. Then after setting smooth, you can convert your mesh into subdivision surface mesh, by adding the subdivision surface modifier. This will further smooth out your mesh. Again, you can add the subdivision surface modifier in the F9 editing context menu.

Another way you can quickly add the subsurf modifier is by pressing:

Ctrl + [1 to 4]

for example, If I want to add subsurf level 2 to my mesh, I would press:

Ctrl + 2

What we tend to do after adding subsurf modifier is to recalculate normals because a lot of the times, when you create faces, some normals point in the wrong direction which causes black streaks on your smoothed mesh. Therefore, we need to recalculate the normals and make them point in the right direction.

You can recalculate normals by pressing Ctrl + N.

Thank you for the replies!
They are a great help.

Especially the part about the normals: now I know this is an important item to remember.

I did’nt know there were shortcuts for adding modifiers and for setting smooth…
That will speed up the workflow because I like to switch a lot between smooth and solid.

But can you tell me how the shortcuts work in Blender 242a?
Pressing w gives me a popup panel and Alt + 3 then does nothing.
And pressing Ctrl + 2 makes the viewport pan instead of ading a modifier.

Thanks, Dominiek.

I can’t really help you with your shortcut-question as I personally add modifiers always using the mouse…and yeah, my shortcut for Set Smooth or Solid is like F9 and click on the button :wink:

But, I just noticed that you were talking about Subsurf Level 5 or 6 in your first post. Now, never ever even think about using such high levels. I’d say, the practical maximum should be 2. If your mesh isn’t smooth enough with a level of 2 (or 3 at most), then your modelling is wrong and should be redone or improved…
Anyway, as it seems, in this case you don’t even need 2, now that you have solved your problem.
And while we’re at it - there are times that even Recalc Normals fails. Then you have to flip normals manually, which can be done if you go into edit mode, select the bad faces and hit “Flip Normals” in the Mesh tools tab.

Thanks for the help!
This stuff is rather important to know and now I know, haha.

Oh, I figured out the shortcuts: it’s not the Numpad keys you have to use but the number keys above the alphabet keys on the keyboard!

Have a great ending of the year, Dominiek.