JPEG Render strange bug at Export

Hi,
I rendered as usual my scene with JPEG render / exporting frame per frame, and it looks like the export totally bug and make the result not usable :

Here you can see the file type is the number of the frame, instead of “JPEG file”
It cause that i can’t use it or even open it, instead of choosing to open each frame manually with the windows photo reader. That is not suitable because it directly rename the frames at “.”, and i need them well named to import the compo in AE (also there are more than 1000 frames lol)

I never saw that kind of bug before… Here are my export settings :

I’m rendering with Cycles. Each frame take a few minutes render, and the scene is very heavy ( + 6GB), i don’t know if it can be related to this.
Anyways i rendered properly already thousands of frames of this movie and i would really love to can finish it. If someone have an idea why it happens, or have an idea of solution, i would be glad to hear from you, thanks!

This bug is very strange and I don’t know how to fix the bug itself but I can write you a small programm to rename all files to number.jpeg so you can use the already rendered frames and don’t habe to rerender them.

But it seems strange, that “File Extensions“ is not checked. I’m not exactly sure what it does but it could be the reason.

thanks for the answer! I just checked “file extensions” and will try to render some frames tonight to see how is it, i’ll give feedback on the result.
I just saw that i confused this file with another well rendered frames file, there are only 190 frames wasted no +1000 so no need to create the programm for it i’ll rerender pretty fast if the problem is solved, thanks for intention!

I just created the script (for fun) and if you (or anyone else) has more frames to fix, just place this file: rename.bat (187 Bytes) in the folder with the bad file names and launch it (double click it). This will rename any file with the format “…number” to “number.jpeg”. Be aware, that there should only be the bad files and the .bat file in this folder.

1 Like

It’s not a bug, you set the filename to be .. so the output will be that with the file number appended. If file extensions isn’t checked it won’t add the filetype suffix

See:

The files are fine, they just don’t have the extensions so a lot of software will think it can’t open them. File extensions are just a label to help identify the kind of file, they don’t technically matter.

2 Likes

Hi, thanks you for explanation i understand better now! I probably unchecked the file extensions involuntarily, now it works perfect, thanks

thanks Patrick for the script, i downloaded it and will test it to save my already recorded frames!