Jumpy IK in render

I use IK. In viewport, animations are smooth.

When rendering however, it’s like one out of every ten frames there’s an issue with IK - and the armature bones affected by the IK kind of jump.

I assume I could fix this by creating frames instead of key frames, but I was wondering if anybody knew how to fix this sort of error.

Thank you!

For rigs that act differently in viewport vs render, first thing I’d check would be to see if there are any dependency loops. Look for “dependency cycle” warnings in a console view (window->toggle system console). If there are any, fix them.

Hey bandages. There were no mentions of dependency cycles in the console.

I assume it would appear when I tried to render the animation? If that’s the case, this isn’t the issue.
Do you have any other suggestions?

Thank you!

I’d have to see a file to tell you any more than that.



Here you go :slight_smile: @bandages

No, a .blend file, not a movie file.

Oops sorry, the second link was meant to be the blend file.


Change the armature IK solver from ITASC to standard. (In properties/object data/inverse kinematics.) I haven’t tested, but I think that will fix it. (It’s acting twitchy even in viewport, although more subtly.)

You probably want the subsurf to run after the armature modifier, not before.

I will try this out immediately and return here with results.

I assumed the modifier order didn’t matter, since I tried to see how things worked in the viewport with subsurf modifiers in effect and it still wasn’t jumpy at all

The subsurf’s not causing the jumpiness, it’s just an extra recommendation, hope it wasn’t uncalled for.

Yeah so everything works but since what you said was uncalled for I’m opting to go back to the buggy setup instead :confused:

Haha jk, but actually - after 300 frames it seems to be working fine.
What is the difference between that and standard?

I’m not familiar with ITASC solver. It’s not the default. I believe it uses the last frame to determine the closest match for the next frame’s IK angles, which means that how it acts depends on what the first frame of the animation is-- ie, rendering from frame 1 isn’t the same thing as jumping to frame 1300 and seeing what it does.

But I’m not perfectly familiar with it, that’s just my impression, and it’s been a long time since I played with it.

I can’t imagine why I had that option turned on then,…

Thank you for your help @bandages!! You’ve saved me a LOT more headache than you could possibly know. Do you have some online profiles on youtube or twitter or somethin?

Nothing in particular, nope. Glad to have been of some help.