Keyframe on mesh doesn't work


(sparhawk) #1

I’m using Blender only for a view days and I didn’t get my books yet, so I need to clarify this here if anybody can help me. I read through some tutorials and seacrhed also the forum and the knowledgebase to no avail.

According to the tutorials I foun you have to use I for inserting keyframes. I created a simple mesh (tube) selected it and inserted a keyframe I->mesh for frame 1. Then I set the frame counter to 250, changed into edit mode, moved some vertices around, changed out of edit mode and inserted another keyframe with I->mesh. Now I expected the object to reset to its original position when I changed to frame 1 but nothing happens. I have the object only with the changed vertices.
Then I played around with trying to set the keyframe while in editing mode and this didn’t work either. The funny thing is that sometimes I managed to set the keyframes but the behaviour was a) not reproducable for me and b) it didn’t behave as I expected.
I always set the frame counter to 250. The few times when I accidently did it right and got the keyframes inserted the mesh transformed but not over the entire span of 250 frames. Instead it did the transformations until about frame 100 and the the transform was finished (correctly). I expected the transform to take 250 frames when I set the keyframes on 1 and 250 but maybe that was the case because I dind’t knew how I set them. Though I’m sure that I didn’t change the frame counter to 100 while playing with the keyframes around.
Any help would be appreciated as I think this would be a trivial thing for any user. :slight_smile:


(mthoenes) #2

It helps to understand Objects and Meshes in Blender. For basic Keyframe animation you want to be in Object mode (Lines). You use the I-Key to insert Location Rotation, Size etc…
Here’s agood tutorial
http://10secondclub.org/users/juicy/keyframing/keyframing.html

The Object’s Mesh is what you access in edit mode (Tab-Key with object selected.) - Then you can edit the vertecies of the mesh.

to animate a mesh in Blender you Set Relative Vertex keys. This is more complicated than Setting Keys for Objects.

I have a tutorial at
http://home.att.net/~alexander.michaels/tut1b.html

This tutorial describes how to set up Relative Keys for a lattice.
The process for a mesh is almost identical but the Relative Vertex Key Button is in a different spot of the animation buttons window.

Look for tutorials about Relative vertex Keys if you wish to distort the mesh.

Welcome - and Happy Blending


(mthoenes) #3

See this Thread
http://www.elysiun.com/viewtopic.php?t=6208


(sparhawk) #4

Thanks! Now it works. My problem was that I didn’t set the first keyframe in EditMode, only with the object selected. Now that I did this in Edit Mode with the vertices selected, it works.
The only other issue remaining is, why the animation doesn’t end at frame 250 where I specified the key.

Thanks for the tut on vertex keyframing. That is really helpfull and today arrived my books aswell. :slight_smile:


(dreamsgate) #5

in the render buttons make sure that the end frame is set to 250


(sparhawk) #6

I checked the render buttons and they are set correctly to Start: 1 - End: 250

I tell you what I’m doing, maybe sombody can verify this and see if this is the same on your machine. It’s pretty simple.

1.) Set Frame counter to 1
2.) Create a tube and switch to EditMode
3.) Select all Vertices
4.) Insert a keyframe on Mesh
5.) Switch off EditMode
6.) Set Framecounter to 250
7.) Switch to EditMode again
8.) Grab a single vertex from the upper part
9.) Press O (for the Magnet Tool) then SHIFT-O
10.) Move the vertex down.
11.) Insert anothr Keyframe on the Mesh.
12. Switch out from EditMode.

When you now move back to frame 1 and play forward the animation is finished at approximately frame 99 instead of 250.
You can immediately verify this as well. When you set the second keyframe and you move back with CRSR-LEFT then the frame counter is reduced, but the animation of the vertex start moving not before frame 99.

The above steps take about 5 seconds to complete, so it is not something very hard to do. Maybe somebody can see immediatly what I’m doing wrong, or is this a bug? I can’t believe that I hit a bug on something as simple and fundamental as this.


(theeth) #7

go to the IPO window and modify the transition curve for the vertex keys. By default, the animation starts at frame 1 and end on frame 100.

Martin


(sparhawk) #8

AAAHHHH! Thats it! :slight_smile: Thanks!
Is there a reason why the vertex animation is only 100 frames by default? What good is it to set the frame counter when it is not set as I adjusted it? That’s not really intuitve. Wouldn’t you expect the key to be set at the position where you specified it?


(theeth) #9

it might seem unintuitive at first, but keep in mind that the control curve for vertex keys will make it easy to switch from on keys to another, so make sure to order your keys (the horizontal lines) in a logical order (bottom -> top = start -> end)

If you need more control, use Relative Vertex Keys.

Martin