Keyframes disappear when animating visibility in viewport

I have found when animating, Disable in renders and disable in viewports using the outliner, keyframes will disappear. For example, you have a cube, at frame 10 you keyframe the visibility in the viewport so you can see it. Then at frame 11 you keyframe the visibility off so it disappears.

Now go to the timeline or dopesheet and move the time indicator to before frame 10. You will see the keyframes, all is good. Now scroll past frame 11. as soon as you go past frame 11 and the cube disappears from the viewport and the keyframes also disappear from the timeline or dope sheet. even if the object is selected in the outliner.

Is there a way to lock the timeline so this doesn’t happen, so I can see the keys of an object if it is visible or not in the viewport? Thanks

The logic is simple, the object that is invisible cannot be selected, thus any data related to the object cannot be seen. That is the reason why dope sheet and others cannot display the object’s keyframe :wink:

Edit: Note that you cannot select the object on frame 11 in outliner, what you are seeing in the outliner is an highlight of the object. The highlight in the outliner helps to navigate through it with up and down arrows when the mouse is in the outliner editor.

Thanks for you comment, I can get the idea behind it, but just because you cant see it in the view port doesn’t mean you may not want to change any parameters on that object.

Lets just say the keyframes for the visibility are at 99 off and 100 on. And I want to move that to say frame 50 to match up with another object. If I am on frame 50 I then need to move the timeline to 100 or above and move the keyframes down to 50, rather than just staying on frame 50 selecting the object in the outliner and moving the keyframes down to 50.

Its not a show stopper, this is the first time I have animated the visibility like this, but it is a bad workflow, you should be able to properly select and change values on an object even if its not visible in the viewport.

And I think you are only partly correct about it not being selected in the outliner if the visibility is turned off. You cant add any modifiers etc but you can still change the scale etc of the object.

You are right in this type of situation a smooth workflow will be to let keyframe manipulation when object is invisible. You can always suggest it to the devs. many be some questions might arise, for instance how to select an hidden object and how to unselect it? Can user multiselect hidden objects? …

This is the beauty of Blender if someone asks for a feature even though it does not align with other principle, if a dev. is willing to code it then we will have

You can do that.

Active object concept is disturbing newbies. The restriction of selection to visible objects is probably to avoid to have them messing up their project.
But I agree that should not happen and is not efficient or a good way to prevent issues.

Anyways, for animators wanting to animate invisible objects, filters of timeline and dopesheet (enabled by default) can be disabled.
In Timeline, you can untick Only Keyframes from Selected Channels checkbox in View menu.
In Dopesheet, you can disable Only Show Select filter (icon button representing arrow of mouse pointer at the right of header) and unable Show Hidden filter.

The problem is when moving to the frame where the object is invisible, Blender deselects the object but the object stays active.

Yes. I am questioning myself.
We probably should report that as a bug.

Active object is still selected in outliner. The default filter in dopesheet is about showing selected object.
Technically, it is no more selected object only in 3D View.
It is still the selection in Outliner and Properties Editor. So, why not, in dopesheet ?

That is at least an inconsistency.

1 Like

I was thinking about it as well, then i wonder about code-wise, it can be pretty complicated, i don’t know. If the author of thread feels like it, he can report it and we see.

I would be happy to report it, Haven’t reported a bug before, where do go to do that?

Thanks

Here is Pablo showing how to do it https://www.youtube.com/watch?v=JTD0OJq_rF4&t=11s however this sounds like a feature request. Do this report the bug first then if it is closed, because being invalid. Go to right click select or devtalk and make a proposal.
devtalk: https://devtalk.blender.org/c/other-topics/user-feedback/13
rightclickselect : https://blender.community/c/rightclickselect/

Thanks, Will do. Have a good new year.

1 Like