keyframing Physics simulation gives weird results

I used the cell fracture addon to cut up a simple object. Then upped the margins between the parts (copied from active in the physics tab), hit play and it gives me a cool explosion. Then I tried rendering the animation on my PC and on the PC of a fried. Somehow his PC calculates the physics differently from my PC and we have different results and can’t use the frames together. Should I stop here already somehow set the physics in the blender project to absolutely fixed values (how?).
But I think I need to keyframe the motion of ALL the little parts flying across the screen. This takes a lot of time but then sometimes it works, sometimes ALL keyframed parts move different after the keyframing, which totally sucks, and even more, they clump together to one single blob again that moves over the ground…
I tried applying loc, rot, scale, all at once, only one of these values, nothing helped. When the origin of every object is in the center of the whole scene the object cluster forms in the center of the scene. I have the feeling when I keyframe more objects together blender somehow uses the median origin of all the objects and puts them together there. Or maybe when the objects are touching while the physics sim run?

How can I keyframe lots of physics sim objects with margin together? Help please. Or how can I ensure the physics sim runs the same on every machine? And can I send a physics sim to a render farm? Or is a keyframed version better?

Hi ToxicTuba. :slight_smile:

As I understand it, your main issue is that you can’t replicate the same simulation on a different machine. To solve this all you need to do is bake your dynamics from rigid body world settings in properties panel>>scene tab. You can pack his file and send it to your friend, and when your friend opens the scene, he should get the exact playback.

Doing this will give consistent results for render farms as well.

Here is a link to a short video I made aboutf it.