Keying Emission Number Workaround


I’m trying to set up a system for a project i’m working on where I create modular pieces for a city and I’m finally coming close to the result I want with hair particles.

The last step I need to have exactly what I want, is to be able to set the Number settings in the Emission tab to be the result of “Y” x “Z”. But I can’t apply any driver or anything to it.

I just want to make the Emission number the result of YxZ.
Does anyone know if there is a workaround for this?

How do you change the object from a 4x2 grid to a 4x3 grid when you edit a custom property? If this is done with python then you could set the particle system emission number from that python code.

As an example: setting the particle system emission number on the default cube from the python console:

D.objects[‘Cube’].particle_systems[‘ParticleSettings’].settings.count = 50

Oh, my bad. Forgot to say how I got this result.

Y and Z are two different arrays. “Y” is driving and array that only affects my “Y” array, and “X” is doing the same for the “X” array.

I originally only was using arrays, but then realized the “Random” setting for the “Object info” node in the “Shaders Nodes”, didn’t affect all the arrays as different objects.

So I figured I could use the particle system to generate instances that would be affected by the random texture.

So I set up a simple plane with the same array system, and made an object that could be used as the tiles.

It seemed to work how I wanted it to!

The only issue is, whenever I adjust the array, I have to manually multiply Y and Z and enter it into the Number value for the Emitters

I’ll try doing something with the Python, but I have tried multiple times to learn python over the past like 10+ years, and I still can’t do anything with it :frowning: