Keying set failed to insert any keyframes

Hi there!,

I’ve got this error and I’ve been reading some similar topics, but noone helped me, so excuse me if I’m duplicating posts.

The fact is that I have an insect with an armature to animate it. This armature has multiple helpers which simulate a walking cycle. To make it I’ve created the first cycle and add a Cycle Modifier at F-Curve window to repeat it. Everything was good.

Then, I’ve created a path which will be the route that I want the insect follows to. I’ve configured the “follow path modifier” at armature object (Object mode) and the path parameters at the spline. Everything was good.

Now, I want the insect, after follow its path and ends its walking cycle, makes some moves again and then, follow another different path. No way. When I’m trying to add a keyframe to one of the helpers I’ve used to create walking cycle using “I” hotkey, the error appears and doesn’t allow me to do nothing. Same error show up when I try to add a new keyframe to the armature object in Object Mode.

Already I’ve checked there is no animation channel locked at F-Curve or TimeLine or DopeSheet windows…
Any ideas?

TY in advanced.
Best regards,


I’ve solved partially my problem. At last, I added a new path and discovered why it was behaving in a strange way. So I’ll explain if someone else has same problem using two different paths for same object:

Create another path curve.
Add another “Follow Path” modifier.
Configure it the way you want (basically start frame-end frame) in modifier’s panel and curve tab.
Then, you have a numeric field called “Influence”. By default its value is 1. With one only path seems to be more or less useless, but when you have more than one and all of them have same influence, you’ll see the difference. So…
Set “Influence” field of the second path down to 0 and the main path up to 1. RC on the fields and “Insert Keyframe”. Then, move to the frame you want to switch your path and “Insert Keyframe” for both of them. Then, on next frame, switch their values 1->0 and 0->1 and “Insert Keyframe” again.
Done. Your object will switch between the two paths inmediatly.

NOTE1: If you leave some frames for transition between two paths it will show a strange effect caused because there will be a moment in which your object will follow both paths at 50%, so its position will be affected by its original position (no path assigned), 0’5 one path and 0’5 another path… It will move weird, maybe like flying around, and can confuse you.

NOTE2: There is a small “jump” in wich your object dissapears and appears again on the second path. Try to adjust as much as possible the end of the first path with the beginning of the second one to reduce this “jump” to minimum. Maybe you don’t need to use two paths and you only need a stop. In this case, just use “Insert Keyframe” at “Evaluation Time” and duplicate this keyframe until the frame you want to restart your movement.

I’m still having same problem inserting new keyframes to my armature in object mode. It looks to be locked but I don’t know why. Waiting for answers.
Thank you in advanced.
Best regards,

What keying set are you using? Try removing it and setting keys manually with i. If that doesn’t fix it, please post the blend.

Hi Cyaoeu and thank you for replying :slight_smile:

I’m using a Follow Path modifier on the armature object. Then, in Pose Mode, I’m using a Cycle Modifier to create a walking cycle on a set of bone helpers.

If I try to add new keyframes on armature object after finishing the path it shows me the error described above. If I try to add new keyframe to one of the helpers which has Cycle Modifier, it breaks cycle animation. I don’t know how to restrict the range I want to cycle (cycle modifier in F-Curve window) and it takes and repeat all keyframes defined.

Can’t post .blend file untill I finish the work, but maybe I can create new .blend file with the same problem if needed.

Best regards,

You may have auto keyframing on with the “only insert needed” keyframe option checked in your preferences (CTRL ALT U). As blender interpolates between values, if that option is on, it will consider that there is no need to insert keyframes on the channels you don’t tweak manually.

You can force keys in your graph editor and viewport in several ways. In the tool panel of the 3d view, there is a button called “breakdowner”, which permits to blend between the previous and next keys, and even extrapolate their values. This forces a key.
In the graph editor, you can select your curves and press I with your mouse over the curves and then select key selected : it forces keys to appear too.
Last but not least, on any curve, you can select a point or series of point, copy it/them and paste it/them wherever your green cross is at. It forces keys too and permits fast editing.

If none of this works, you should try to post a blend file, yup.

1 Like

Try making the action cycle in the NLA editor instead. It’s Repeat under Action Clip in the n-panel. If it still doesn’t work you could make seperate actions for the walk cycle and the path and layer them in the NLA editor.

Hi Valerien and hi again Cyaoeu. Thank you for replying.

I’ll try to reply in order:

I don’t have checked the “only insert needed” option. The only option I have checked is “Show Autokeying Warning”. Maybe I should have another options selected (I didn’t change the default values).

I could not find any button called “breakdowner”. I’ve looked for it at Object Tools panel (T) and at Properties panel (N). I’ve tried to find it using “space bar key” and search it on Addons panel. It wasn’t there. Maybe I should download some addon, but don’t know which one.

To press “I” key at graph editor rises up the same error (it is what I was doing in the beginning).

I don’t know how to copy-paste frames to do what I want, because I have a curve, but it’s an “Influence” curve which determines how much path influence affects to my armature. It’s not a position curve, so I cannot copy-paste a keyframe to edit armature’s position :frowning:

This is the first time I look at NLA editor. I’m confused and I don’t know how to use this window. I should have to check it out and spend some hours making tests.

I’m feeling like a newbie (I am, actually) and I can’t spend more time on this. I give up. I’ll patch it as I can and hope to have more time in my next project to fix this error if it appears again :slight_smile:

BTW: very nice sculpting Valerien (I mean your avatar). Really nice one.

Thank you very much for your time. I hope someday I could help you too.
Best regards,

Yeah, the NLA editor is pretty confusing at first. Anyway, the cyclic modifier is probably interfering with something and making it impossible to add keys. That kind of makes sense, because if you make the animation cyclic the armature just repeats whatever happened before. That’s why I suggested to use the NLA editor, because you can remove the cyclic modifier, open the NLA editor, click the snow flake…thing, then you get a bar for your animation which you can repeat (under playback settings). You can also change the blending mode to Add and add the curve action above the other action to have them play at the same time. This would have to be a separate action for it to work.