Kill Particles in fluid simulation

Hi All,

I’m really struggling with a problem around fluid simulation. I have the simulation sorted. However, due to particle lag there always seems to be some left at the bottom of the render. My idea for a fix on this is to kill the fluid particles after a certain time. However, the collision effector “kill particle” doesn’t seem to work on fluid particles. Any ideas?

Linked is a short video with settings as I cannot upload.
Fluid Lag Simulation

You can use a flow object with Outflow type.

1 Like

Absolutely brilliant. This must have completely slipped my mind. When you’re bogged down in simulation settings its easy to forget there’s often a simple solution