Knife Midpoint Issue

Hello blenderartists

I’m using blender 2.69 in Ubuntu 13.04.
I was following a tutorial by ianscott88 from youtube about making a low poly sports car. I found a problem here because mine just different than his tutorial. He was making a cut by knife and press CTRL while knife is active to make it midpoint snap. But the problem is when I was doing the same thing with my blender, it shows different result. I doesn’t really snap all the edges at the midpoint but only the last edge that is snapped at midpoint…

here is the tutorial:

And here is my project, sorry I cannot capture my screen while I press the CTRL key. But the result whether I press the CTRL key or not, is the same. The green dots are not in the middle of the edges.

Pls help to solve my problem. Thanks

The tutorial which I was following actually uses different version blender than mine. He uses blender 2.67 and I use blender 2.69 in Ubuntu.

If adding loop cut is not possible then with knife hold Ctrl and click for every edges.

The knife tool’s midpoint finding ability is confused by the subsurf, but it will mostly find and cut in the middle of the original geometry. To see where it is cutting you can turn off subsurf (click the eye) while using the knife.

@Tynka Yes, I have to do knife - midpoint snap - for every edges. And it is very annoying.

@DruBan I didn’t use subsurf in this condition. It’s only normal edges.

I found this is a bug for Blender 2.69 in Ubuntu. (I actually have dual boot OS in my laptop) I have tried the same thing in Blender in Windows and I found no problem doing knife-midpoint snap- for multiple edges. The one I did in Windows is exactly the same one I did in Ubuntu and it works perfectly.

Now I want to report this bug, where should I report bugs and how?

Could you explain why you would need this functionality for knife if Ctrl-R does the same by default?
Even if you wanted to middle cut part of the mesh - hide edge in front and end of the cut.
Which functionality you are looking for or what does not work as expected, image just to be sure:

You could post a file on which it happens consistently for someone to try and reproduce the behavior to see if it really is a bug. Right now I cannot reproduce it; the knife’s midpoint snapping seems to work correctly for me on Win 8 64 so it would have to be someone on Linux.

I have the same problem than starter. Win7 64bit, Blender 64bit official r 4b206af.

I hink I see the problem but it’s not a problem. The knife draws a straight line between clicks. If you hold ctrl down as you drag over edges it will offer you the option to click and set a point at the midpoint of that edge. If you do click it draws a straight line between your last click and the newest click, creating as many interpolated vertices as necessary, in a straight line. If you want every single crossed edge to be bisected then you should be using loop cut or perhaps edge select mode and subdivide but if you want to use the knife then you will click on each and every edge as you cross it and if you are holding ctrl down the vertex will be created at the midpoint.
BTW I think this is what Eppo is saying only differently. This is not a bug but the only reasonable way to have the midpoint option set up IMO.

Exactly, which gives one a tool to selectively cut in halves edges leaving the rest cut by straight line. No other tool does that; J could be the closest after recent updates.

Thank you.

Exactly again. The knife tool is the most versatile tool for retopology in Blender and Howard (applause!) really has polished it to a fine edge recently. Now it’s a scalpel! The J connect has only one thing to recommend it: it’s only one keystroke. But the knife happily alternates cutting edges with changing cut direction by creating vertices in the interior of faces (although perhaps a very greedy person would want the option of snapping to face centers with the control key down - hint, hint) and you can cut and snap to newly knife created geometry immediately so you can keep working without interruption.

In fact it’s so much fun to use compared to the hoops you had to jump through before that you can easily get carried away and create way more geometry than necessary.

Midpoint snapping is now back to same behavior than long time ago.


Sad news, indeed.
/uploads/default/original/4X/b/5/0/b501f9502911d573f495acc3286cbda9a71c34a4.pngd=1387537959 - this is not possible anymore?

I think not possible without subdividing end edge and snap to that middle vertex.

That would be: 1) Shift select 2 vertices; 2)w menu Subdivide 3) select Knife and start point 4) snap to the end. Which was one key press…

Start with Ctrl knife and release Ctrl then you need only end edge subdivided already :slight_smile:

Oh yea… Exactly what i had on the list… :). I will use J likely instead. It would also involve subdividing some edges but then there is no need for Ctrl anymore :).