Knife project No other selected objects have wire or boundary edges to use for projection

When I try to use knife project (Blender 2.93.4), I get the error, " No other selected objects have wire or boundary edges to use for projection). While trying to figure out how I could be doing it wrong I came across a post on Blenderdev that said this describes the error so that people would know what the issue is, but obviously, I don’t know what that phrase means. Can anyone point me in the right directions?

I made a new file, created a plane and a cylinder, in object mode I selected the plane (the knife), then shift selected the cylinder (the object to cut), tabbed in to edit mode and selected Mesh>Knife project, and get the error.


1 Like

I got blender (2.93.0) to that point by tinkering around, and then to a point where blender would not do knife project without an error. Both times tab out and back into edit mode seemed to fix it.

1 Like

I found this shortly after posting this question, but I guess I still don’t understand because I can’t get it to work. Good luck.

1 Like

I had the same issue with knife project. Then I deleted all the faces of my knife object keeping only the vertices & edges, it worked pretty well as I wanted.

Dang, I just tried that on a new file. Made a plane, delete the face only, tried it on the default cube, same error. Oh well.

1 Like

I was going to submit a bug report and came across this way, so I was just doing it wrong.


Just in case you didn’t find any solution, I got it working by duplicating the edge and then converting it to a standard poly curve

Hope this helps


This is soooo unintuitive and such an unnecessary change. I cant think of one reason this needed to be implemented as any sort of fix or quality of life change, even with the changes it wasn’t even clear on the documentation on why it was changed. But nevertheless thanks for the video, helped me well


Old Blender versions can works with only one object in Edit Mode, but new versions can works multiple objects. For this reason, old methods not work (yes, this is a bug).

Select main object, after that enter the “Edit Mode” and select extracted object with SHIFT key in the OUTLINER window and after that click “Mesh > Knife Project”.


Thank u so much!!!

this was really helpful. thank you

A couple of things…
First and foremost… Knife project works best in orthographic views front side top etc…
Second…It works better if first, you select the object to be cut…enter edit mode and Ctrl+ select the Cutter or Cutters in the outliner… then select Knife Project…pay attention to the pop up lower Left if you want it to CUT THROUGH the object…

1 Like

I just had the same problem
Thank you

wow, it works, thank you :pray:

1 Like

I have to agree with most comments, it isnt working with any mesh and the error still persists, but thats normal for blender. Curves and boolean are its weakness. Hikmets solution doesnt work in 3.5

It works just fine…but there is an error in Hikmets solution…

1: Select the object to be cut…
2: Enter Edit Mode, and Ctrl + L-click on the cutter object ( IN THE OUTLINER )
3: Select Mesh > Knife Project ( not the new Knife Topology) select in lower left if you want Cut-Through or not…

Blender 3.5


I solved my issue with Knife project just separating the faces into my cutter object.
I was building a fence cutter and it doesn´t worked. Just separated the faces using edge split and worked !
Thanks guys!

thanks. the explanation make sense and it worked for me except it wasnt SHIFT, it was CTRL.

1 Like

Yes, that is what I stated in my breakdown…But I edited it with a Bold-Face Font just to make it stand out as all the older tutorials had it as Shift-Select which does not work…