Knife Tool Only Snaps to Center of Origin 2.9

I’m cleaning up my mesh after combining multiple primitives and beveling multiple edges. I’m trying to use the knife tool but the square indicating it is on one of the vertices only appears when I hover on the point of origin. Occasionally, it will snap to an edge near the point of origin. When I try to select any of the vertices far away from the point of origin, the knife tool does not recognize them and I cannot left click to begin making a cut. This is true when I toggle the knife snap function on or off. Quitting and restarting blender did not correct my issue.

I am confident there is a setting I unknowingly changed in blender and this is a quick fix.

I just started having the same issue on some of my models. Haven’t figured it out yet. Changing the origin of the object moves the square and I get the knife icon, but it won’t start a cut.

If you’re confident it’s because of a setting, you could try starting a new blend file and appending the old one in. Maybe even factory reset Blender.

I did some testing with other models, and huh, the knife tool worked. Had to be the specific object file I was working with. Appending the OBJECT to a new file worked for me.

Thanks!

1 Like

Yeah, my workaround was to export as an .stl and open it as a new file in blender. Not what I want to do every time it pops up, but for a small project, it worked.