Latest 2.8 builds: instant crash on opening

Is anyone else finding that attempting to start the last couple of 2.8 builds results in an instant crash?

I get the usual Blender small console pop-up before the main app screen opens, but as soon as the main screen tries to load 2.8 immediately crashes. This is with the official builds from the 2.8 project, not with the new compiler builds, and is on a W7 64 bit box.

Did happen when first builds start to roll out… every time was solved by Clearing preferences!
‘userpref.blend’ in Roaming/2.80/config/…

Better?

1 Like

Nope it worked without crashes for me, although I did not stress it.

Still quite impressive for an early WIP.

I had the latest 64 bit compiled with VS on Win 10. So maybe try other builds.

Not really, because there is no such file. :smiley: The only userpref was in the 2.8/config folder in “Desktop”. It never made it as far as AppData.

@kilon: have tried two different builds on two consecutive days, so am not sure another build will make much difference.

you got me there :wink:
ok, onto next best thing

  1. run cmd
  2. blender.exe –debug or –debug-all (drag&drop ‘blender.exe’ and type ‘–debug-all’, hit enter)
  3. command prompt will stay open even after Blender crashes, so you can see what’s going on…

ie.
com-prompt

1 Like

Ok, will grab the latest build and try that.

Ok, here’s the output:

C:\Users\Peter>C:\Users\Peter\Desktop\blender-2.80.0-git.ba80d84-windows64\blender.exe –debug-all
Win32 Error# (3221692565): <no system message>
Win32 Error# (3221692565): <no system message>
found bundled python: C:\Users\Peter\Desktop\blender-2.80.0-git.ba80d84-windows64\2.80\python
Error: Cannot read file 'C:\Users\Peter\ÔÇôdebug-all': No such file or directory
Error: argument has no '.blend' file extension, not using as new file, exiting! C:\Users\Peter\ÔÇôde
bug-all
Saved session recovery to 'C:\Users\Peter\AppData\Local\Temp\quit.blend'

Blender quit

I just noticed that the actual code in your screenshot uses a double hyphen in front of “debug”, whereas your text suggested a single hyphen. Tried it with both, but get the same output either way.

I’ve had a look at the quit.blend but it doesn’t seem to contain anything interesting. It has a note about Evee being missing, as you’d expect when it was opened in 2.79, but nothing else.

that auto-text formatting :roll_eyes:

yes, it’s double hyphen for first & single for second argument…
check more on Command Line Arguments - Debug Options

Ok, does this make more sense?

C:\Users\Peter>C:\Users\Peter\Desktop\blender-2.80.0-git.ba80d84-windows64\blender.exe --debug
Switching to fully guarded memory allocator.
Blender 2.80 (sub 17)
Build: Thu 06/07/2018 04:27 AM Windows Release
argv[0] = C:\Users\Peter\Desktop\blender-2.80.0-git.ba80d84-windows64\blender.exe
argv[1] = --debug
read file
  Version 272 sub 2 date unknown hash unknown
Win32 Error# (3221692565): <no system message>
Win32 Error# (3221692565): <no system message>
found bundled python: C:\Users\Peter\Desktop\blender-2.80.0-git.ba80d84-windows64\2.80\python
Error   : EXCEPTION_ACCESS_VIOLATION
Address : 0x000000005C4F9FC0
Module  : C:\Windows\system32\nvoglv64.DLL

vrooom - vrooom… buggy driver :smiley:

1 Like

Cool. Updated the driver and it works now. Thanks.

1 Like

just mark as solved

Done. :slight_smile:

(I didn’t realise we had the solved tag in this board)

2.8 looks pretty good for an alpha build. Some of the choices seem a bit iffy, but it’s still in flux so we’ll see how it goes.

it’s not in “alpha”. There’s no qualification yet, it’s just in “development” and many newly added things are still about to change so don’t worry too much.

hmm interesting I did not there was a debug flag for the command line, I thought that was only for the debug builds. Thanks for this, it will come very handing now that I am developing my own fork for Blender.

I’m late to the party, but I have had the same problem with the daily builds for the past week or so on both my Windows 7 machines and my Linux machine. Sadly, I have no say over the Windows drivers and will have to beg the Tech Dept. here at work. But I will try that on my Linux machine. I’ve been putting off the latest driver because I was in the middle of something and both 2.79b and the 2.79 git builds were working fine.

So that’s to the OP for the post. I know it isn’t just me. :grinning:

Mine started crashing on startup too (Linux). Dumping info here since bug reports aren’t open yet:

[27b67340222] seems to be the commit that it started happening.

Terminal Output
./bin/blender
Color management: using fallback mode for management
Color management: scene view "Filmic" not found, setting default "Default".
Received X11 Error:
        error code:   182
        request code: 156
        minor code:   34
        error text:   GLXBadFBConfig
Received X11 Error:
        error code:   182
        request code: 156
        minor code:   34
        error text:   GLXBadFBConfig
Warning: Could not find a matching GPU name. Things may not behave as expected.
Received X11 Error:
        error code:   8
        request code: 156
        minor code:   34
        error text:   BadMatch (invalid parameter attributes)
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  156 (GLX)
  Minor opcode of failed request:  5 (X_GLXMakeCurrent)
  Serial number of failed request:  200
  Current serial number in output stream:  200
System

Manjaro Linux
AMD Quad Core
Radeon HD 7660D (open source drivers)

OpenGL

OpenGL vendor string: X.Org
OpenGL renderer string: AMD ARUBA (DRM 2.50.0 / 4.14.48-2-MANJARO, LLVM 6.0.0)
OpenGL core profile version string: 4.3 (Core Profile) Mesa 18.1.1
OpenGL core profile shading language version string: 4.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.1 Mesa 18.1.1
OpenGL shading language version string: 1.40
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 18.1.1
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:

I had problems loading 2.8 on my fedora 28 machine. No errors - just a flash on the screen and that was it.

I ran “blender -debug” and got the following:

[[email protected] blender-2.80-01f576e87b-linux-glibc219-x86_64]$ blender -debug
Read prefs: /home/userid/.config/blender/2.79/config/userpref.blend
unknown argument, loading as file: -debug
Error: Cannot read file ‘/home/userid/blender-2.80-01f576e87b-linux-glibc219-x86_64/-debug’: No such file or directory
… opened default scene instead; saving will write to /home/userid/blender-2.80-01f576e87b-linux-glibc219-x86_64/-debug

Interesting that it’s trying to load a file it hasn’t created. Only problem is - it opened 2.79, not 2.8.

nancycat: you need to use two hyphens in front of debug, that is: --debug
Not sure why you are passing that argument, but if you want to, that’s what you have to do.

“burnin” indicated the command above, but the new forum converts double hyphens to single hyphens if it is not written using “code” format in forum.

1 Like