Lattice deform only moves plane in 2 dimensions and shrinks faster?

Nothing is locked, I already checked. The lattice only scales width or height, not depth and the lattice shrinks faster than the plane. I need to extend it for a boolean mouth, but so far it’s been frustrating. I also tried undoing and ticking the “apply” option in the lattice deform creation.

This might be because the lattice interpolation type is set to BSpline. Try setting it to linear or something else that meets your requirements.

That fixed the shrinkage, but it still won’t thicken the plane mesh, which is invisible from the side.

Are you trying to give a plane a thickness with the lattice modifier? That won’t work. The lattice modifer won’t create new geometry.
Perhaps you can put a solidify modifier before the lattice.

But it would be best if you posted an image of what you have and what you are trying to achieve.

Lol, I feel extremely stupid for not just doing that in the first place. Thank you for your help!