Leg popping to side with Rig


Any Idea how to fix this issue?

Even though the poll target is in front the leg still pops to the right when lifting. The rig was done with the legs straight down and not with a slight bend but the style I’m going for the character needs to be straight legged and I don’t know how to offset the legs without the knee ball funking out.

i’ve tried limit constraints on the top leg to stop rotation but for some reason it has no effect, maybe the IK takes priority?

The yellow bone should have menu below when selected. Try locking different axes.

Yeah they don’t seem to make any difference :frowning:

Here’s a blend file if anyone has any ideas. I can make it work if I put a slight bend in the knee, but like I said this one needs to stand straight and the way the knee is modeled Ie Mechanical and not organic, I cant seem to get it to work.


righelp.blend (1.24 MB)

Nevermind. Got it to work like you said. Strange, just a reload of the file got it to work.

IK Solvers require a slight bend to give it a direction in which to calculate. If you don’t have that bend, it doesn’t know what direction you want it to go, so it can be really funky. So the correct solution is to put a slight bend in it, then you can use your IK stiffness or axis locks.

If you need to have a bone chain perfectly straight, you can use the trick in this video to solve the problems created by straight bone chains and IK constraints. The explanation starts at the 14 minute mark. I highly recommend this tutorial series, Humane Rigging.

Good luck!

cheers Dannyboy!

hmm, that looks ok but where it gets to the part where you right click on the rotation for the drivers it differes from the older version of blender and nothing I do can get the drivers to show

It looks the same to me in 2.77a.

Can you put up a sceenshot?

click any one of them and the eyedropper tool appears, if i select the bone nothing appears in drivers screen

never mind, found it…pheeew this rigging malarkey :smiley:

Humane Rigging is awesome, it has taught me so much. So I concur, watch all of it!

Yeah its really good. Problem im having is where dan said about the trick for straight arms and legs. Blenders changed a little it seems or im clueless.

If i can get the drivers to show up they have empty info. Not like when nathan does it on that video. Cant figure it out

Did you turn off the IK constraint before posing the leg? Turn off the constraint influence, pose the leg to bend in the direction you want the knee to bend, turn the influence back to 1.00, add drivers to the rotation transforms of the leg. No need to configure the drivers. Nathan is just showing the default driver setup that is added.

If you can’t get it sorted, post a blend and I will take a look. You may have something else causing a problem.

OK here’s a file. I’ve actually got around the problem by resetting the rig to a new pose mode but its not ideal and im going to come across this problem again when I start the next character. All I’ve done in this file is bend the knee so you can see how it bends inwards.

I can do the trick that Nathan shows but when I go to the drivers part, right clicking on the rotation panel it looks completely different from on the DVD. Then If I add them manually (the only way I can get them to show up in driver screen) there is no data.


righelp1.blend (1.32 MB)

Simply lock the z and y in the inverse kinematics panel on the shins. :slight_smile:

I’m not sure why the add drivers option is not showing up for you. It works for me.

Did you customize any key mapping? You might want to revert to the blender defaults if you did.

Good luck!


That’s blender default. Only things I ever change are lock camera to view

Actually, that build is from graphical.org but I thought they were the same, it was trunk stable build

Ahh I just seen what you typed sorry. The add drivers does come up for me but they there’s another screen with 4 or 5 different options…not like in Nathans video at all.

I’ve tried all the options and the only ones that show up in drivers tab are the manual options. But then they have no data


Even though no data appears, all the boxes turn purple and it works as it does in the video minus the data in drivers tab. I must be funking it out, I mean it works I would just like to know why and how.

I’d start by using a version of blender downloaded from blender.org instead of anything found on another site. There are many test builds out there for people trying to add to or fix multiple issues. The current version at blender.org is 2.77a.

It’s the only thing I can think of causing that extra menu. I guess it could be an addon causing it.