Les Paul - very noisy

I know you probably get this question often, but i’ve been sitting for hours trying to figur this out without much improvement…

In my Yafaray renders I get a lot of white noise artifacts:
http://chrisweb.dk/res/example.png

some of my settings are:

AA helps a little but not on the spots that are very noisy…
If you have any ideas on how I can get rid of this noise, please let me know:-)

-Add AA passes
-Lower Pixelwidth, I usually us .01
-Increase depth, ray depth, and shadow depth
-Use Gaussian instead of Box

See how that works.

Thanks for the suggestions rvngizswt… But that didn’t do it.
With these settings:

I get this render:
http://chrisweb.dk/res/example2.png
actually a bit worse:-(

Haven’t used Yafaray a lot but I don’t think you understand it’s AA passes or maybe I don’t. :slight_smile: hehe You have it set at 5 passes, with 5 samples in the first pass, increasing by 1 sample each pass there after. That is nowhere near enough samples, but maybe ok if it’s just test render, re jagged line of humbucker mount.

Try 3 passes, 8 samples first pass increasing by a multiple of 4 samples each pass there after. Something like that anyway, long time since I used it.

The white dot’s I guess is photons / path samples problem.

As an aside unless you’re on a Mac, change your gamma in for textures and gamma output to either 1 or 2.2. 1 for a linear workflow, 2.2 for gamma encoded. Not that it will do anything with the specks.

thanks, i didn’t knew that yellow…
I tried 3 passes and 8 samples, but that didn’t help either:-(
I don’t think AA can remove this much noise.
I think the problem is elsewhere… maybe the light setup or the materials. Just can’t fugure out what.

If you have lights close to geometry, move them.
If you are using sphere lights, check their size, they are bigger than you think.
If you are using IBL, try a different .hdr, or increase samples.
Try reducing the glossy settings on individual materials to find which one is the problem(if any).

Pixel Width 1.5 is fine.
Turn down Shadowdepth and Raydepth, 20 is too high for that context. 5 is ok.
Use gauss or Mitchell (Box is faster, Mitchell is sharper)
Use 2 AA Samples, and 2 inc AA Samples, with say, 10 passes. You can stop the render at any time if it isn’t working out.

If none of that helps, post up the .blend file (or at least the problemmatic parts of it), and I will check it out when I get home.

:slight_smile:

Hey organic

Thanks for the tips! I’ll try Them out when I get home from my little weekend getaway…
If it doesn’t work out, can I still PM the .blend file next week? It would be cool if you will look at it:-)
By the way what is IBL and .hdr? - guess I’m not using it since I don’t know what it is:-)

Here’s my settings and the result. Default scene, and sun instead of lamp(maybe your problem?).

Attachments


Sure, no problem, I will still be here. :slight_smile:

IBL is Image Based Lighting - using an .hdr image as a light source.
.hdr is High Dynamic Range images - sometimes used as an environment map for reflections, or as a light source in cgi.


That helped… I think my main problem was that I had world background color set to black and had some lamps with power set at about 1500. By using a light background color and a sun I get rid of the noise:-) But now all colors looks faded and the materials appear different:-(
http://chrisweb.dk/res/13.9_with-white-world.bmp

Try turning down the strength of the lamps.

rvngizswt: I have turned down the power of the lamps a lot and now use black background again.
Actually I think the noise problem was caused by the glossy material type… the noise occurs when trying to make chrome material with that type… Shinydiffusemat works much better.

Any chance you could post the file? I also think it is one or more of the Glossy materials / lighting set up.

organic: yes i’ll post it to you… 2 sec…

It is the materials. The Diffuse component for the chrome was too high, and was causing sampling problems I think. It looks better now I hope:-


I just realised I messed up the yellow plastic / bone material, I thought it was shiny metal too. :o

Can’t win them all…

The file link should be with you already Chrisweb :slight_smile:

organic you are a genious man! That looks perfect:-)
Thank you so much!!