LibFree() or LibLoad() crashes Blender on Windows

Operating System: Windows 7 64 bit
Blender: 2.69.0 (r60995)

main.blend (470 KB), prop.blend (481 KB)

I have prepared demo files above. Main.blend uses LibLoad() to load prop.blend and frees it with LibFree() if it is loaded.(Press space.)

When doing this couple of times, Blender crashes. It doesn’t crash on Linux machine so I can’t understand what is wrong or if I’m doing something wrong.

Any assistance would be appreciated.

I’ve had problems with LibLoad/LibFree on and off. I filed a bug awhile back:

Although I was having the opposite problem where it would crash on Linux but not on Windows.

I added checks and tried adding delays, but the crashes were always random.

With me, in the main.blend it always crashes when the Scene is LibLoaded a second time (although it had been freed). It has nothing to do with storing it in a property on the GameObject, that’s for sure, and the code seems fine. So it must be a bug. Hope it will get fixed.

Working perfectly for me on Blender 2.69 running on Windows 7 64 bit.

Did you press the spacebar more than two times? Because in Blender 2.69 Windows 7 64 bit (which I am running also) it crashed with me. If it works for you, then maybe it is an issue with the graphics card? (mine is nVidea Geforce GT540M).

Yes I pressed it several times, the cube appears and disappears over and over again…
And I don’t think this has something to do with your graphics card, since I have a GEFORCE GT540m as well :wink:

I tested that with my own game, the first time I tried it crashed but no more time after that.
Is it happening consequently on your pc?

Yes. I don’t understand why you’re not having the same problems (now already with two things - referring to removing vehicle wrapper wheels). Consider yourself lucky! :slight_smile:

Raco yes that is strange, but I think that is not really my luck, but more your bad luck :wink:
Because I have tested this on 3 different PC’s, and it worked on everyone of them.
But that’s not that unusual, even expensive software just doesn’t work on some PC’s!