Light distance setting not honored in BGE?

Hi,

I am currently experimenting with the Blender Game Engine (2.49) and have run into a problem: I would like to adjust the light distance of a lamp, but changing that doesn’t seem to have any effect on the rendering in the game engine - the light radius is always the same. (In Blender’s normal textured 3D view, I see the difference.) Is this a feature not implemented in the BGE? That would be a real pity.

I attached the test .blend file as a reference. Thank you for your help.

Attachments

LightDistance.blend (913 KB)

enable glsl then you ll see the difference, multitexture is an old render method.
Go to game and and click on the GLSL

Thank you, this fixes the light distance problem. However, all my former UV textures now disappeared. How can I get them back?

I have fixed that myself. I have not set the material texture’s type to “Image”. Weird it worked with multitexture then, though.