Light Groups Composite is Darker Than View Layer's Combined Pass

Hello, I’ve been watching a few Youtube tutorials on compositing light groups and they all use mix nodes set to add in order to combine them. I assume the result should look exactly the same (besides the exponential glow nodes for the head and tail lights, which are not the issue) as the view layer’s combined pass or the render layers node’s image output, which are the same thing. The composite ends up always having slightly more contrast for all six of my different cameras + lighting setups. I’ve checked all manner of settings in the compositor, outliner, properties, etc. and I’m stumped. I’ve also tried condensing the lights into fewer light groups, which doesn’t solve the problem and also defeats the purpose of using them. The first image below is the light groups composite, the second image is the default view layer render, and the third image is the compositor node tree.

1 Like

Are you adding the world (HDRI) lights?

1 Like

Hi there, Use Nodes is unchecked in the world tab of the shader editor. I also have Transparent checked in the render properties panel > film. Here’s all that’s connected to the world output node:


I should note that the background object that the car is sitting on is basically a beveled cylinder with flipped normals and the top deleted. I’ll experiment with closing it to see if it makes a difference.

Sorry to reply twice in a row, but adding a top to the room object worked and now my composite matches the original view layer render perfectly. I’m not sure why this happens since I’m not experienced at rendering, but alls well that ends well lol.

Turning Use Nodes off just means you don’t have the control of using nodes, the environment still is emitting light. Transparent in the Film settings means the background renders transparent, not that it stops emitting light.


Ah, I see now that I can leave the top of the room open and disable the environment by going to the properties editor > world and setting the strength to 0. The original problem is that the view layer combined render automatically takes the environment into account and I neglected to add it when compositing. I don’t suppose you know how I can add it if I wanted to use a background/world color? The environment render pass is rendering as completely black for some reason.

You can add a light group for the environment light. And then add that on top of the lights.

1 Like