Light isn't showing up on textured surfaces. :\

I know this is probably a rookie mistake, but i’ve just started texturing my game with GLSL enabled, and now my spotlight (3rd person camera mounted flashlight) wont shine onto the textured surface (the ground), if anyone could tell me what im doing wrong that would be great, im kind of at a stand still until i get my lighting fixed.

also its got this ambient light or something… that’s coming from no where and i dont want this, i want to create all the lights myself, so that some spots in the game will be too dark to see without pointing the flashlight in that direction, again, thanks.

A .blend would be nice, but off the top of my head check the outliner and make sure renderability isnt clicked off(the little camera icon).
If you parented a spotlight to a flashlight mesh then make sure the light reaches far enough out to interact with the ground. If you didnt stick to blenders default scale then you might have to use extreme light property setting.

I think you have a material with a texture, right?
Try a few things:

  1. Set the material to “face texture”
  2. In the textures tab, set the “mix” mode to “lighten”

I did what you told me and still nothing… i made an example of what im talking about, do u think you could tell me why its not working at all? i obviously dont know what im doing when it comes to lighting textured images.Light-to-texture_Example.blend (543 KB)

Try packing the texture…
(File->external data->pack into blend file)

The two buttons I mentioned are here:

i found the buttons you were talking about, i guess “pack into .blend” does what your asking.Light-to-texture_Example.blend (1.11 MB)

I just tested out your blend and found the spotlight worked across all surfaces even the textured one. You have a Hemi light in your scene if you want to know where the additional light is coming from. Also your cone is shadeless on my comp.

what should i do, are there any settings in my blender that i could change? or should i try another blender? im using Blender 2.54 Beta, in that test scene the cone is not shadeless and the light does not shine on the grass surface, i was aware of the hemi, it was there to shine onto the cone to show if it was shadeless or not. thanks for you help… i guess this it going to stress me out a little but im glad there’s other things to work on before i start texture raping my map… thanks for your help.

Try turning off GLSL, and putting it back to multi-texture mode.

ya, the light is shining on the texture now, its just really dim, do u think its my graphics card? i already am aware that my graphics card is a piece of crap, really did want to use this GLSL shading but i guess i can do without… do you think that if i downloaded another version of blender it would start working? or do u think its purely my graphics card not being good enough?