Lighting Problem

Hello,
I am getting some problems with my objects… some faces have a dark corner like in the picture below, and when I put a texture on it (I am using Unity) it looks weird. Am I doing something wrong?
(1)

It looks like the geometry is weird…How did you model this…did you use a solidify modifier?
I just made up a wall like the one you show …
1> add a plane…rotate y 90 ,scale Y till size…duplicate and move Z (absolute grid snap on)
2> add a plane, rotate 90, move z (absolute grid snap on) till between top and bottom sections, move Y with (snap to vertex ) and snap to bottom plane corner, duplicate and move Y to other side…
select all>Join…Extrude X for thickness…result is this

I did not use any modifier… just did it in edit mode

Try and Recalculate Normals (in edit mode, select all and Ctrl+N).
Also, set Shading as Flat.

do you mean shift + N? it did not work… I ended up making a new one

1 Like

Probably better in the long run…It did look as if the mesh was triangulated and the weird shadows are from the faces …sometimes in that case rotating the edge ( where the shadow starts) will get rid of it. Good luck with this!

It can be… I thought Ctrl+N was the default.

Anyway, if you have such problem with a so simple mesh then you should investigate a little further instead of giving up, to improve your knowledge.

You could maybe try to Remove doubles and recalculate normals again, who knows.

It could be a simple problem for you =)) but I can’t fix it.
Here is the file if you want to try it yourself.


Thanks for helping anyway!

I didn’t mean the problem was simple, no problem is simple until you solve it, I mean the mesh is simple.
I will open your file ASAP.

1 Like

Your problem is that your object has a few ngons in it, and some co-planar faces. It’s pretty easy to fix with welds.

I’d fix it right now, but I’m about to head out to the store. If no one does it before I get back, I’ll bang it back together, and send the results your way.

1 Like

You don’t have to, I already made a new one.
And thanks for finding out the problem!
Thanks to all of you who helped me out, have a good day! :grinning:

1 duplicate vertex, 1 loose vertex, 1 degenerate face, Custom Split Normal Data to remove, some Unwanted Sharp Edges, some n-gons, so many issues for a ‘so simple mesh’!
Here the file anyway:BuildingParts.blend (386.7 KB)

1 Like

Really that many? :0 wow, I am really bad :rofl:
I’ll look at the file to see what you changed.
Thank you!
Have a great day!

Thank you.
You’re not bad, those problems come from the importing, but we must learn to investigate, that’s important.

1 Like

Can I disable shadows? I get this weird shadows when I export the objects…

I can’t get the meaning, perhaps you need to set Shading as Flat, I don’t know Unity.

And, I realized that in my file I forgot to Clear the custom Split Normal Data on the “Wall” object, but you can do it yourself from the object Data panel -> Geometry Data.

1 Like

Setting Shading as Flat helped, thanks!

1 Like