Lighting Problems (Still...)

Well, I’m still stuck in my lighting problems with my music game. It’s the same as before: I can’t get both lights to work in one scene. I’m writing this again because now I’ve got photos that may help explain my problem. In the first picture is the highway where the notes come down. one light, as well as the camera, are parented so this layer works as the HUD. In the second picture both layers: the Action layer and HUD layer, are placed in one scene in game. Here’s where the problem is. The HUD light doesn’t work at all now and the HUD uses the Action layer’s light which is darkened. This cripples the game for me because of odd lighting problems, I’ve tried everything I can But I just can’t get it to work. Can anyone help me?


Well I have this annoying problem with 2.48. Try to use 2.45 and see if this problem is still there.
Otherwise, try to re-texture and re-light all of your objects or place all of them in only one layer, this seems to fix it but it is not a good solution.

Alright, I can try that. I just don’t wanna re-texture the entire game (Although I don’t have too many textures, but still.) and I don’t wanna start all over.

Yes,me too, so try to start it with Blender 2.45 and see if the problem still persist.

I tried 2.45, and it fixed it! Although, the walls are missing, I’ll get by. I just wish I could get it working in 2.48.

Ughhhhhhh, Blender 2.45 is so different! I’m going to have a harder time doing this than I hoped.

I have solved your busted lighting problem, layer only lamps work when the objects they are lighting don’t have the same material. So you have

-Lamp 1
-Lamp 2
-Cube 1
-Cube 2

-Lamp 1 and Cube 1 are on Layer 1
-Lamp 2 and Cube 2 are on Layer 2
-If Cube 1 and Cube 2 have the same material, Lamps 1 and 2 illuminate both objects
-If Cube 1 has a different material than Cube 2, Lamp 1 only lights Cube 1 and Lamp 2 only lights Cube 2

It works with GLSL on, but not with multitexture materials, use GLSL to use layer only lamps. It’s a bug with multitexture materials.

Ooooooo, that sucks for me. Oh man, I need a new computer. Darn you mutitexture materials!

Edit: Wait! Why can 2.45 use layer only lamps, yet 2.48a can’t?

Things break with development apparently, or when multitexture materials were thrown out of priority due to Brecht coding GLSL. I’m sure the bug wouldn’t be terribly hard to fix, make sure Ben2610 knows of the problem as he’s the lead BGE developer.

Move the background layer to a different scene, and add it as a background scene in-game. Problem solved.

Hmmmmmmmmmmmmmmmmm… That could work.