not sure what I am doing - new to Blender - but I have generated my lightmaps - then I deleted the spotlight used - and all my textures went black. So how can I see my textures + lightmaps in texture mode?


Under my lightmap texture I have now checked Emit and Color under “Influence” and it has sort of worked. Model seems washed out tho - no lights and darks - just greys.

Is there no easy way to see my lightmap and texture together properly?

You need a light to see any textures, it´s just how it works.
But now your object is shaded again, which you don´t want as you baked lighting, shading and shadows most likely. You got to check the “shadeless” checkbox for your material.

This way you have a “fake uniform environment light” and your material has no shading, specularity whatsoever. You just see the lit texture you baked.

If you don’t want to use a light, you can press “n” to bring up the properties panel and under “view” check “texture solid”

If you’re in solid mode now you’ll see the texture as well, but it’ll be shaded by the default 3 OpenGL Lights, so you got to check “shadeless” again for your material.

Actually, to make lightmaps work you need to just disable color under influence, enable RGB to intensity and enable emit under shading influence. No need to set material to shadeless.

You just enable emit.
If you disable Color and check RGB to intensity your texture will appear grayscaled.

Usually point of lightmaps is also to be able use dynamic lights in scene, so making anything shadeless really kills that possibility.

That is just how blender wants lightmaps, there is no correct way to use colored lightmaps in blender IF you also want to have good quality on your diffuse,spec and normal textures.

In this next example red and white light are bakedOnly and blue and green are realtime lights.

This is wrong looking lightmap, texture is baked in to lightmap which is wrong because quality of our textures are really blurry.
If we now add this as our texture on our object, enable color and emit the result will be like this.
Dynamic light will not work as we want em, but all the baked light colors look nice but as I said, texture quality is not that good. This is how it looks closer to the surface.
Too blurry for any real use.

This is correct looking lightmap which AFAIK blender can’t use correctly. Baked by making every material white with a bit of yellow tint added, no textures at all.

We add this as a new texture for our material after all the normal Diffuse, specular and normal maps. Set influence as emit and rgb to intensity and we will get this kind of result.
Texture quality, baked shadows and lights looks nice but all the baked color are lost.
Dynamic lights works nice which can be used to fake colored lights.
Normal maps and specular maps also works.
Here is how it looks close.

And here is how Beast, lightmapper used in UDK and Unity, bakes lightmaps.

So conclusion is, someone needs to add proper support for correct ligthmaps to blender.

If I am wrong, please correct me.

Thanks for your help.

I am generating lightmaps to take into Unity.

Do I need set my lights to Ray Shadow - not Buffer Shadow?

I have set my AO samples to about 15+ but my lightmaps still seem blocky - if I use Ray Shadow they seem better tho.

Also I am trying to bring in two UV maps - one with a diffuse texture - the other the lightmap.

I simply added a new UV map to my mesh and called it lightmap. This way it uses the same UVs as the diffuse UV map. Why would
anyone use Lightmap Pack?

Am I doing things right?

Can you show a picture of your model and lightmap.
Imo, Ray shadows are better.
Usually you should use UV channel 1 on the tiling textures and UV channel 2 for the lightmap.
Uv channel 1 (for tiling textures) usually will be scaled over the UV space and some UV’s might be overlapping. UV channel 2 (for lightmapping usage) must not have any overlapping UVs and th UVs must stay within the UV space.

Lightmap Pack is a fast way to get a “good” UVs for a lightmap but it is far from perfect.

You can bake lightmaps in unity if you don’t want to do it in blender. It is much easier in unity anyways. Unity will also make lightmap uvs for you if you want.

My bad - brainfart. I wasn´t seperating lightmap and baking light into a texture really.
OFC lightmaps are grayscale. Blender just doesn´t do it right - or at least I don´t know how.
And yeh, setting to shadeless isn´t doing any good if you export on the material settings, but it makes the texture visible in Blender without lights and I doubt the shadeless material property is exported anyways :slight_smile:

So if you put the diffuse texture in one slot set to color, and the same texture with RGB to intensity in another slot and set it to emit you see the texture lit by a “pseudo-lightmap”

If you just check shadeless, you see the texure without shading just as you baked it.

Both not really desireable, as it´ll look quite different in your game engine.

And the lack of GI in BI and the difficulties to bake several objects into one map, especially automated, makes Blender not exactly a great tool for baking lightmaps. Maybe it comes with cycles.

I can recommend Giles though, a GI/radiosity lightmapper. It´s free too: