Lights in BGE not working


I have a problem. The lamps in the blender game engine do not light up objects like cubes. I have a cube with the default material assigned, and I have GLSL enabled. The energy of the lamp is set to 100.0. Why is the cube showing up as dark. Please reply ASAP. This is giving me a difficult time.
Here is a screenshot:

Thank you!

This is giving me a difficult time.
That’s what you are also doing for people who may wish to help you.

Maybe you could actually do a useful thing and add your blend file so we can see rather than having to use guesswork to figure out what your scene settings are ?

Does the cube has any material and do you have turned the texture-mode on?

I forgot to post it. And i am new to this site, hence I didn’t know how to upload.

Use the “Go Advanced” Button, dont use “Post Quick Reply” there you find the Option below to “Manage Attachements” a klick on that shows a new Window with new Options.

You can Upload a file via klicking “Add file”
After your Upload check the Box below the File in the Overview and finish the Post with the Button in the right left corner “Done”.

Now, Good luck :slight_smile:

Here is the .blend Light.blend (407 KB)

Move the light so it illuminates the side faces
Flip the normals of the faces to light the inside

I flipped the normals. But when I bring the light to one face it only lights that face and it doesn’t light any other faces. Here is a picture: