Lights passing through objects?


(dante) #1

I’m using a spot light but it seems to shine through a lot of objects…how do i keep a spot ligt from shining through them?


(theeth) #2

Is the Shadow button in the Display Buttons window (F10) turned on?
Are those objects in the clipping distance of the spot?
Is their material set to Traceable (On by default)?

that covers just about every problem that can happen.

Martin


(dante) #3

What is the clipping distance and how do you adjust it? I have checked and rechecked the other things you mentioned…


(pamtango) #4

Select your lamp, go to lamp settings window, near center left bottom you’ll see the settings for
Clip End:
Clip Sta:
You put a numbers in here, you’ll see a line that extends from your lamp with dots defining the beginning and end points.
You might also check your
Dist:
setting at the top of the lamp window near the center.
Check also that none of the materials you’re using in the ‘see through’ objects have less than 1.0 Alpha settings. This make them transparent to the degree that the Alpha is set below 1.0.
Hope this helps,
Pam :wink: