Lightsaber Plugin 0.4.1, tutorial added 3/07 (pg5)

Alrighty, latest version here:
Binaries for various platforms can be found scattered throughout pages 4 and 5 and here:
Tutorial is here:

If someone could compile this for windows blender, or tell me how (I already tried the lcc-win32 compiler with no sucess) I would greatly appreciate it.

same here. The guide refers to a file called seq.def, which I can’t find. I also get a couple warnings but they probably aren’t crucial.

and don’t forget about the OSX users :slight_smile:

The seq.def file and all other files needed are in the plugins source archive at the blender plugin repository. I have these files and tried compiling several of the plugins available there. My .dll file would not work and ended up being 12kb while the pre-compiled ones were ~230kb. So I don’t know what I am doing wrong.

Finally I got this thing to compile on win32… 8)

The first problem(it not compiling) was due to a lousy compiler. The second problem(weird colors) was due to the inconsistency between the win32 and linux platforms-- I had to change all instances of char to unsigned char. go figure %|

Thank You very much. I’m damn glad you took the time to mess with a dll version of it.
What compiler did you end up using?

how do you use it?

The source archive that I linked to in the first post has a README that should explain it.

Grizzly69: hey, no problem. 8) I wound up using MinGW/dev-c++, basically gcc for win32. SirDude gave me some info about cross-compiling from linux to win32 using gcc, so I just used the same commands with gcc-win32 that he uses on linux. It’s a heck of a lot smaller, too :smiley:

anyway, I’m gonna need some serious crits here… I already see a few problems with the quality myself.

Also, if anyone gets it running on macosx or some other platform please let me know, I’ll host it.

I ran into a problem with it while animating a cylinder. It seems there is a blank spot where the cylinder is at one time that never goes away. I did a basic animation of the cylinder from one side of the camera to the other. When I played it back I found that it passes a black blank spot as if the cylinder was rendered black shadeless. I am at work right now, I will post a pic or vid of what I am talking about later on.

Just try what I did and see what you come up with.

Okay, here is a small divx clip of what I am talking about:

hmmm, I also had this problem on winxp although not on win98 or linux. It looks like a platform-specific bug which’ll make it harder to track down :< bleh

ok, to fix that problem run it in compatibility mode for windows 98.

Worked for me, thanks again qwe.

were do i place it to use it?

the read me tells me nothing on activating it or anything

It’s a sequence plugin. You need to learn about the sequence editor. LUCKILY there’s a video tutorial showing how to use the glow effect in the sequence editor that you can find here

It explains it quite well. For the litesaber plugin, just select Plugin where he tells you to select Glow in the tutorial and find the plugin.

i don’t have any kind of media player to play the movies and my internet connection is so slow it would take me over an hour per movie so has any one made a word document?


Open up blender, make a cylinder that looks like a pipe. Give it a material, make it all white, hit the Shadeless button.

Now go up to the top and you’ll see a drop down box that has soemthig like Screen.001 in it. Drop that down and go to Screen.002. If that’s not there, just split your window and make one window the Sequence editor.

In the sequence editor, go to Add, then Scene. You’ll get a confirmation window with the number 1 in it. Click that. Now you’re scene bar is in grab mode, so click to place it.

Now go to Add and to Effect and select Plugin. Find the Lightsaber.dll and click it in. A new bar will pop up, click that down above the scene bar.

Now Left click in an empty space above these two bars, this moves you to a frame along the sequence that will have the effect in it.

Now go to your Scene options window, (F10), and select the Do Sequence button that’s below the big Anim button. Hit F12 to render, and the effect will show.

I ran into the same WinXP issue myself. I’ll try Win98 compatability mode but it would be nice if the problem was correctable without having to do so.

why does the glow fill the entire screen?