Limited loop cut \ Problem with knife tool

Hello everyone!
Is there a way to create some sort of “limited loop cuts”?
I would like to be able to create something like this on the fly (see image01, light blue area).
The dark blue area shpws an example of the original geometry. Let’s say I want to create the cuts that are done in the light blue area in the dark blue area quickly. Is this possible?
Also, I tried using the knife tool for this (see image02). I used the mid points functionality each time and cut along the area. But then, each time I try this, something weird occurs (see image03 or image04 (image05 shows the same situation as image04, only in wireframe-mode).
Does anyone have an idea? How can I do this and how do I avoid knife-tool problems?

Thank you very much in advance!


image01

image02

image03

I can only attach up to 3 images per post.


image04

image05

Please delete

If the loop cut is terminating, it is either running into a triangle, n-gon, or the end of a valid manifold face loop. Check for duplicate faces/vertices (W>Remove doubles with the whole thing selected in Edit Mode) or for a rip in your mesh (just grab the edge where your attempted cut is terminating and move it around. See what happens). If none of that makes the source of the problem obvious, attach your .blend file so we can check it more thoroughly.

Thank you very much for your answer!
I checked the mesh and I haven’t seen any problems. Also, removing doubles will delete 0 vertices.
Here is the .blend file:
[ATTACH]282650[/ATTACH]
Maybe you can see the problem.

Invalid attachment. Try again please, or post it to www.pasteall.org/blend/ and give the download link.

The attachment works okay for me. I’m confused.

Maybe this time?
loopcut_untitled.blend (505 KB)loopcut_untitled.blend (505 KB)

Or maybe this?
http://www.pasteall.org/blend/26246

Actually it turns out I breezed through your original question too quickly and thought you were asking something different. Oops. I basically answered the opposite of what you were asking, so you can reverse-engineer a useful answer from my previous reply:

Loop cuts will follow a valid quad face loop until they either close or reach a terminating point. Things that can terminate an edge loop include: triangles, n-gons, ends of face loops. To do what you want, take advantage of the last of these. Hide the faces you want the loop to end on, then do a regular loop cut with Ctrl-R. I’ve done exactly that in the attached file: loopcut_untitled1.blend (465 KB)

You’ll just need to un-hide the uncut faces with alt-H. Note that by doing this, you’re creating n-gons. Watch out. N-gons can cause shading and deformation problems, especially when they’re long and skinny like yours. As previously alluded to, they can also cause problems with loop cuts, since you need quads for loop cuts. Generally speaking, you should only use n-gons as a stepping stone to fully quad-based topology.

Thank you very much for your answer, K Horseman!
Hiding the faces I want the loop cut to stop works perfectly fine! I don’t even seem to get n-gons. Why do you think the geometry uses n-gons? When I select four edges of the geometry that is being created after a loopcut using hidden faces, a complete face will be selected.
Will there be further vertices generated when performing this?
Also, I just found out that, when problem with the knife tool occurs, I can perform “Remove Doubles” afterwards which will remove one or two doubles and seems to fix the problem. Then, I can put the edge where I want it to be.
But I really like the approach with hiding faces better. It’s more straight forward and you can directly put the edge where it is supposed to be.
Also, I want to use the geometry in a game in Unity 3D which means I have to use Tris when exporting anyway. Do I have to watch out for something then?

EDIT:
Ah, now I know. The hidden faces will become n-gons! But I can Triangulate those, right?

Yes, but better to create quad topology yourself. Auto-triangulating n-gons can get unpredictable and messy. The best solution I’ve seen for game triangulation is to make good clean quads with good edge flow, then use a triangulate modifier, which gives you a bit more control over the direction of triangulation.

To create a limited loop cut I use this sequence of commands:

  1. Loop cut. Ignore that it’s too long.
  2. Circle select to deselect the parts I want to keep with the middle mouse button.
  3. Ctrl-X to dissolve.

It’d be nice to get a real edge offset op, but this sort of works, except in a situation where loop cut crosses itself.

Piotr Adamowicz, thank you for sharing this! At first glance, I was pretty impressed how easy this is. But then again, this workaround creates n-gons all over the place. The whole loop cut is still there, so to say. Only the edges aren’t displayed. Unfortunately, there are just as many vertices as the complete loop cut creates.

@K Horseman:
Actually, I would like to use some n-gons to be more flexible when working on a mesh. Also, I can change the mesh quicker when using n-gons at certain points. When I finish a mesh, I want to triangulate critical n-gons separately so that nothing is messy. Do you think this is a good way to go? I do have a variety of n-gons which also have a very different amount of vertices. I’m not sure if a modifier that works with the whole mesh is a good thing to use then.
Also, some geometry can’t be made of quads quickly, I guess. For example, creating a circle and pressing F will immediately create an n-gon circle but when I want the circle to be made of quads, thats more tedious, isn’t it?

EDIT:
I just tried using Triangulate Faces on an n-gon circle and using Tris to Quads afterwards. This method didn’t work. I guess, a circle can’t be made of Quads. Maybe I’m wrong there, though. At least, it doesn’t seem to be easy.


Just like so, easy ;).

Oh you can use n-gons to your heart’s content while you’re modeling; just keep track of them and clean them up before finalizing the mesh. eppo’s suggestion of Grid Fill will work for a lot of cases. W>Bridge Edge Loops will also help in other cases. You can also select opposing vertices across an n-gon and hit J to create an edge between them. When all else fails, you can always keep using the knife tool if there isn’t enough geometry to fill in quads in an area.

Oh that’s right, I did a little customization there and totally forgot about it - in your preferences go to the input tab, find the ctrl-x dissolve operator (use the search bar), expand it and check “Dissolve verts” in its options. Then save your settings. Now you shouldn’t be getting any more stray vertices.

@eppo: Alright, I didn’t know “Grid Fill”. Thats easy indeed! Thanks! :smiley:
@K Horseman: Thank you for your help! I guess using J can be really helpful! Also, “Bridge Edge Loops” can really save a LOT of time in some cases!
@Piotr Adamowicz: Awesome! Thanks for this hint! It works! Well, at least most of the times. I don’t know what I did wrong, but sometimes there have been n-gons even though. Do you know what could cause this problem? Right now, no n-gons seem to appear any more, but I would like to not create n-gons accidentally. :slight_smile:

Also, I’ve still got a question about the knife tool. It the problem I ran into something that will only occur when using midpoints? Because it really seems to add doubles where it’s not supposed to. Well, at least in the way I tried using it, you don’t want the doubles to be there.