Lines around certain objects? (Hair-related, I think)

Hi. I’m sorta, but sorta not, new to Blender. I guess I could just say it’s been a while.

Anyway, I’m having a problem where I get a sort of outline on certain parts of my render. It looks to me like the hair and the model are not lining up correctly. This is not too noticeable on smaller renders, but I’m doing a massive one - 4000 x 3000, and it becomes very noticeable, as you might imagine. It’s going to be in a 22-by-something frame and put on display, so… I might not want this massive gap showing. :stuck_out_tongue:

I am only using Blender’s internal renderer. Should I give Yafray a try? I shudder to think how long that might take to render. With blender’s, it takes about a day on a 2.66 GHz quad-core machine (or about 90 hours on a 1.83 dual-core machine - random info from experience, haha). I guess that’s not too bad for that size, it’s not a very complex image, except for the 30,000 strands of hair.

I’ll try to render a small section and post it if needed, as well as my render settings.

Thanks! :slight_smile:

It is hard to know exactly what you are talking about w/o a pic

perhaps you can post a smaller version - or crop the section you are having the problem with

it also might have something to do with the display (ie. if you are displaying a 4000x3000 image on a 1024 screen you might be getting weird aliasing that only displays weird but is not actually in the render)

but it also sounds like you might be using more hair particles than you need to
have you tried to use hair children (makes it easier on the CPU)?

Here’s a picture of what I mean. There’s like an outline around the ear, in this case. It seems as though Blender skips rendering of hair around this object and lets the background show through. It’s not just the ears, but (seemingly) anything in front of the hair.


Looks like a compositing error or premul error. If you are compositing stuff on top then try using premul button in mix nodes. If not try to use the Full Sample Antialising. To activate you have to first activate save buffers and then the full sample antialising.

Cool, thanks musk. FSA seems to have fixed it. Now for a full raytrace… fun.