Linux: Save as runtime

Hi community,
I have a problem running my exported game under linux (lubuntu 12.10 64bit / blender 2.65a)
Maybe I’m doing something wrong or the export function has issues.

The export consists of only the binary file and the python folder. Is that correct or should there be more files created?

I cannot mark the binary as executable through the preferences. As soon as I tick the corresponding box the checkmark disappears again.

chmod +x filename

runs without errors in the console but the file is still not marked as executable nor runs by



Have you got any advise for me?
I did the export twice with the same result.

Thanks in advance.

I cant tell why, but it seems that it is not enough to have executable rights for the binary. The file also needs rights to be readed.
So changing them by entering

chmod +r filename

should do the Job.

I presume because the .blend file is bundled with blenderplayer as bytes it will need to be able to read the contents of the executeable.

Make sure you’re not exporting the executable onto a non-Linux file system. For example, I have this problem if I try to run a Linux executable from my removable hard drive (that has an NTFS file-system from Windows on it). If I copy the executable over to the native Linux file system, it works fine.

Thank you all, it works now.
I saved the runtime on my ntfs gaming partition. After moving the files to a ext4 partition everything runs fine. :slight_smile:

Guess it’s an issue with the ntfs driver which doesn’t allow to mark a file as executable.