Logic node trees aren't working when I export my game (UPBGE)

Unfortunately I can’t share an example blend at the moment but I’ve tried both game exporting addon options and multiple variations with each of their settings and none of my Logic Node trees work when I launch the game. I only have two node trees and they both work when I launch the game from the project file using the embedded player option and the standalone player option.

I’ve done several google and youtube searches for solutions to this problem but they all bring up problems with texture/material nodes, not logic nodes.

As always, thanks in advance for any and all help.

1 Like

So first off I wanna say I’m a bit of a dumb*ss. I saw that the node trees were saved externally and I tried copying and pasting them into the game folders but I didn’t even think to do it to the folder it self.

Thank you very much. I think I need to go take a nap now.

1 Like

This was a face palm to me when I figured it out but I also couldn’t find instructions anywhere.

I take note to modify the export addon to check if a bgelogic directory is available where the main .blend is and to copy it to the executable location.