Loonix


(rndrdbrian) #1

While in the newsagents yesterday, I spotted that the August issue of Linux Format DVD had the complete distribution of Slackware 8.1.

So I bought it.

Question is, should I install it as a second OS on my system (WinXP on at the moment, got a spare drive for linux)?

Anyone else use Slackware?

Is it good, or is it pants?

Thoughts please!


Brian


(Eric) #2

Yes.

Yes.

And yes, it’s great. :smiley:


(rndrdbrian) #3

Lol, Well I guess i’ll be spending this afternoon installing slackware then!

:smiley:


Brian


(valarking) #4

more like this week. :wink:


(rndrdbrian) #5

more like this week. ;)[/quote]

Well, got slackware installed, got all confused at setting up Xfree86.

Think I’ll stick to WinXP :x


Brian


(Timonides) #6

Well…

Just out of curiosity, what was the problem with XFree86???

I mean since it is the latest slackware distro, it should have the latest xf86-4.2.0!!!

Unless you have an extremely new video card, it should be auto-detected, or with minimal configuration…

My SuSE-7.3 works o.k. with my ATI RAGE FURY vivo!!! And I have xfree-4.1.0!!!

skontar.


(rndrdbrian) #7

Heh, it’s probably due to the loose nut behind the keyboard! :stuck_out_tongue:
Think what I should due next time is print off some docs from the slackware dvd, then install, instead of trying to do it blind!


Brian


(Eric) #8

Heh, it’s probably due to the loose nut behind the keyboard! :stuck_out_tongue:
Think what I should due next time is print off some docs from the slackware dvd, then install, instead of trying to do it blind!


Brian[/quote]
Don’t say it’s too late to do it now…did you fail so extremely? :smiley:


(mrmunkily) #9

don’t worry, he’ll be back.

I came back. Even after mandrake linux 6.0

now that distro was wayyyyy pants.

ugly polka dot pants.

now mandrake is really slick though. If it had kde3 i’d have it installed. Alas the beta uses gcc 3 and won’t run a lot of stuff, including lightflow.


(Timonides) #10

rndrdbrian wrote:

Heh, it’s probably due to the loose nut behind the keyboard!
Think what I should due next time is print off some docs from the slackware dvd, then install, instead of trying to do it blind!

O.K. and don’t forget to clean up the keyboard this time!!! :smiley:

mrmunkilly wrote:

don’t worry, he’ll be back.

I don’t worry. Once they start once, they always come back!!! :wink:

May I propose SuSE. For the next attempt??? It worked fine for me!!! :wink:

skontar


(rndrdbrian) #11

<Terminator>

I’ll be Back!

</Terminator>


Brian


(sofort99) #12

I am beta testing mandrake9.0beta2 right now…getting ready to d/l beta3. It is SUPER SWEET and will be absolutely ideal for your first distribution IMHO. Mandrake 8.2 is pretty good for a first time too.Mandrake seems to be trying to make a distro that is good for a newbie…but good for a user too!

:o Rc1 is due out in september…:o

mrmunkily…it has KDE 3.0.2 :wink:


(Grizzly69) #13

Just last week I setup a dual-boot with win98 and Mandrake 8.2. Out of the 3 Distros (Redhat, SuSE, Mandrake) I’ve messed with over the years, I must say, I like Mandrake the best. This is the first time I got the Nvidia drivers to actually work instead of trashing my X11.

I like Mandrake’s RPM setup and utility much better than the other 2 distros. I agree that they are trying really hard to make this an easy linux to use.


(rndrdbrian) #14

Hmmm… Reinstalled slackware 8.1, cannot for the life of me get USB working, which means my usb hub doesn’t work, nor does my usb mouse…

:frowning:


Brian


(acasto) #15

May be a kernel thing


(rndrdbrian) #16

That’s just what I was thinking, acasto. On the slackware CD there are a whole load of precompiled kernels, one of which, is the base kernel compiled for usb support.

For the 3rd install, lol, I’ll tell slackware to use that kernel off the cd and copy it to the boot disk.

One thing I may do is put the usb to ps/2 adaptor back on the mouse, and connect it to the computers spare ps/2 port.

It’s all fun and games until someone loses an eye…


Brian (off for the 3rd install)


(rndrdbrian) #17

Well, 3rd time lucky! :smiley:

Got mouse working (using ps/2 port). Usb hub has its lights on, and the wacom tablet has its status light on OK. Wacom doesn’t move pointer yet, but that’s probably sortable, must read the Wacom-Howto.

Only problem is, screen stuck at 640x480! :x

However, installed the latest nvidia linux kernel & glx, got them installed without a hitch & I can use dynamic blender!!! Yay!

Had to switch from using the CMR modem to my trusty external modem (I had been planning on doing this anyway… Internal modems suck. Listening to an MP3 file and then hearing the internal modem dial up through the soundcard is annoying to say the least!)


Brian


(acasto) #18

You will probably have to recompile your kernel for wacom support. There is special USB driver in kernel for it. Also a few other little settings need set in there.


(Timonides) #19

Hello rndrdbrian!!! :smiley:

I wanted to reply earlier, but seems you’ve allready solved your mouse problem.

Anyway your problem doesn’t have anything to do with kernel. You can verify by issuing at the console:

linux# lsmode

This gives you a list of all the modules that are loaded at that moment. If you see the modules: input.o, mousdev.o, usbcore.o, usb-uhi.o or usb-ohi.o and hid.o, you have usb support allright and your problem is 100% with xfree86.

I think it is xfree’s configuration once again… You can solve it permanently with out the need of that usb to ps/2 adaptor, if you edit manually the /etc/X11/XF86Config file.

You can do the following from the console (always as root):

linux# gpm -r (just in case gpm is working, warning you are going to loose the mouse!!!)
linux# mkdir /dev/input
linux# mknod /dev/input/mice c 13 63
linux# modprobe mousedev

Then, open the XF86Config file, (usually in /etc/X11/XF86Config) with a text editor such as pico:

linux# pico -w /etc/X11/XF86Config

Go then to the Device line of the Pointer section and replace /dev/psaux or whatever there is, with /dev/input/mice.

When done save the file and issue:

linux# gpm -m /dev/input/mice -t imps2 (to reload it with usb mouse support)…

…and restart the Xserver (with Ctrl+Alt+BackSpace). Relogin!!!

This should do the trick.

About the Wacom tablet I don’t know but I think the solution is similar, to the above. Find an entry which resembles a tablet input device in XF86Config file, and point it to the apropriate usb device. Anyway, if I find anything, you’ll be the first to know…

I hope this helps you a bit more…

May I propose cinelerra for video/audio editing of your Blender animations??? It really rocks… :smiley:

skontar.

p.s.: In cases the mouse fails you can always get out of X11 and bring a console so you can issue some commands, by pressing:Ctrl+Alt+F1 (only you have to relogin). You can go back to X11 with Alt+F7 I think.


(rndrdbrian) #20

Thanks for the info, Skontar.

I’ll print it out for future referance. Not going to dabble with it tonight!

cheers


Brian