Loop question


I’m trying to understand some basics about loops and topology. The sticky topic in this forum was a great read but I have to admit some of it went over my head a bit.

I made a short video of a common situation I face when modeling: A loop is broken and I don’t know how to fix it. I also wonder why a vertex is not part of an edge even though it seems to lie on the same place in 3D space.

Any help is appreciated!


first off: your general problem is that edges do not “know” that at the point of crossing another edge, they need to connect to that point. You have to break them apart to have a “connected” crossing.

to connect the edge with the vertex, you highlighted, do the following:
select the edge, then subdivide it.
the newly created vertex is in the middle of the edge, but you want it to be in the same place as your “unconnected” vertex from the video: select it, turn on snapping to vertices, press G to grab the vertex, then constrain the movement to the axis running along the edge (in your example: press X) then move your mouse over the “unconnected” vertex and confirm.
you now should have two vertices in the same place or very close together: Remove doubles or merge the two (alt+M) to finally get the desired connection between edge and vertex.

however it’s not advisable to construct your mesh that way (i.e. having edges cross each other without vertices connecting them) in the first place, because fixing this for a complex mesh can be very nasty.

hope this helps a bit

J05EF explained intersecting edges well. What you have in your model is two intersecting edges that are not connected. Basically, the vertex in the vertical edge loop is merely overlapping the horizontal edge, not connecting with it. There are many different ways you can fix this situation. Which one works best/fastest for you is going to be a matter of experience and personal preference.
What I recommend is to set you view to solid (Z), set your select mode to Faces, select the two large faces adjoining the long horizontal edge (as shown in one of the attached pics), delete those faces (X, note that you will be given a couple of Face delete options, I recommend just selecting Faces, this will remove the adjoining edge of the faces you are deleting, but experiment with this to see what the different options do), set your select mode to Edges, select two of the short vertical edges and then fill (F) in the face. Repeat the edge selection for the last section and fill that as well. This should fix your situation.
I just noticed you might have an interior face in your model. Select that face and delete it, this will also help with some of your issues.